Bug 180765 - /etc/pm/hooks/50modules incorrectly quotes $SUSPEND_MODULES
/etc/pm/hooks/50modules incorrectly quotes $SUSPEND_MODULES
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 23:57 EST by Bojan Smojver
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 04:53:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2006-02-09 23:57:10 EST
Description of problem:

In the for loops of this script (only the resume loop really matters, as rmmod
appears to be doing the right thing), the $SUSPEND_MODULES variable is in double
quotes, which makes multiple modules specified in /etc/sysconfig/pm file appear
as one word, therefore not modprobing modules properly on resume.


Version-Release number of selected component (if applicable):
0.09-1


How reproducible:
Always.


Steps to Reproduce:
1. Put at least two modules in /etc/sysconfig/pm file (e.g.
SUSPEND_MODULES="button natsemi"
2. Suspend using pm-hibernate.
3. Resume - modules won't be there.

  
Actual results:
Modules don't load, because modprobe thinks everything after the first module
names are parameters used for that module. Each module should be modprobed
separately.


Expected results:
Should load fine, which it does without double quotes.


Additional info:
N/A
Comment 1 Phil Knirsch 2006-02-24 04:53:48 EST
Just verified this and removed the wrong double quotes from the script for the
resume and the suspend case as the manpage for rmmod doesn't mention that
multiple modules can be removed at once.

Fix should be in next build.

Read ya, Phil
Comment 2 Bojan Smojver 2006-02-27 04:48:43 EST
Strangely enough, I didn't see that in Rawhide yet...

Note You need to log in before you can comment on or make changes to this bug.