Bug 180770 - Installer crashes using a NFS install
Installer crashes using a NFS install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 03:19 EST by Justin Zygmont
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 11:54:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Zygmont 2006-02-10 03:19:59 EST
Description of problem:

Anaconda runs into numerous selinux problems with a custom install. You perform
a NFS install, with a custom layout and you can see many selinux errors from one
of the background consoles.

Version-Release number of selected component (if applicable):

Fedora Core 5  Test 2


How reproducible:

Always


Steps to Reproduce:

Choose a NFS install, custom layout, select packages, then wait about 5 minutes
into the install, and watch the tty console fill with selinux errors, then crash
and reboot
  

Actual results:

here's an example:

AVC denied {transition} for pid=610 comm="anaconda" name="libgcc_post_upgrade"
dev=hda2 ino=1358789 scontext=system_u: system_r: anaconda_t:s0
tcontext=system_u: system_r: rpm_script_t:s0 tclass=process

and many many more with name= write, connectto, search, execmem, use, depmod, etc.

crashed installer, reboot, unusable system


Expected results:

sucessful install

Additional info:  I can't understand why selinux has to be used for the linux
install
Comment 1 Jeremy Katz 2006-02-10 20:44:57 EST
We have to have policy loaded so that we can set xattrs properly, but we're
running in permissive mode, so none of the messages should be fatal.  Can you
provide the actual messages you got when it crashed? 
Comment 2 Justin Zygmont 2006-02-13 00:17:33 EST
I see, The problem is there is no error message at all, and even if there was
there's hardly any time to see because it just reboots itself.  I have had this
problem with FC4 also, and to some degree FC3; all tested on different computers
too.  However in text mode it does sow an error: Install exited abnormally ... 
I can try and get the whole message, but it's didn;t seem to indicate anything
that I could tell.  Do you know if this could have something to do with an
already known problem.  The amount of packages selected to install seems like it
might be a factor.

Comment 3 Justin Zygmont 2006-03-05 01:48:47 EST
Since Core 5 Test 3 came out, the problem seems to have improved.  I wonder what
changes were made, it could provide some clue to where the source of the problem
was.  Also, with T3, it was interesting that my test installs would have better
success with more ram being added, adding more than 256 MB of ram seemed to help
the install go farther along before it rebooted.  Here's some details:

Text mode install, custom layout, 256MB or more, no swap space
P-III 866, 20 GB HD

All it used to say before the crash was:

Sending termination signals... Done.

...



Hope this helps...
Comment 4 Jeremy Katz 2006-03-06 11:54:20 EST
We've fixed cases where ram usage was spiralling out of control post-test3, so
this should be better for the release

Note You need to log in before you can comment on or make changes to this bug.