Bug 1807704 - Events page results with multiple selected needs to be one output [openshift-4.4]
Summary: Events page results with multiple selected needs to be one output [openshift-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1796522
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 01:44 UTC by Zac Herman
Modified: 2020-05-04 11:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1796522
Environment:
Last Closed: 2020-05-04 11:43:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Multiple filters works well (204.65 KB, image/png)
2020-03-06 06:33 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4571 0 None closed Bug 1807704: Show multiple resources in single event stream 2020-04-22 16:31:12 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:19 UTC

Description Zac Herman 2020-02-27 01:44:43 UTC
+++ This bug was initially created as a clone of Bug #1796522 +++

Description of problem:
4.4 Events now can support multiple selected resources and the results are shown in different sections.  The results should be combined into one results list.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Login into Events page
2. Select 2 or more resources
3. Multiple sections will appear with the event results

Actual results:
Multiple sections appear (one for each resource type)

Expected results:
One list of events should be shown

Additional info:
If it is too much work to combine the results, then we need to make the sections collaspable like the new search page.

--- Additional comment from  on 2020-02-07 04:01:05 UTC ---

Setting target to 4.5.  We should fix 4.4 if possible, but I don't believe this is a blocker. Functionality is not broken, but it puts work on the user to mentally sort events.

Comment 3 shahan 2020-03-06 06:29:40 UTC
Selected POD&RS to filter the events, the result related to pod&rs will show up in one stream not two section.
4.4.0-0.ci-2020-03-06-033233

Comment 4 XiaochuanWang 2020-03-06 06:33:19 UTC
Created attachment 1668009 [details]
Multiple filters works well

Comment 6 errata-xmlrpc 2020-05-04 11:43:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.