Bug 180773 - ahci probe failure
ahci probe failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: FCMETA_SATA
  Show dependency treegraph
 
Reported: 2006-02-10 03:50 EST by Richard Tresidder
Modified: 2013-07-02 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 11:41:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Tresidder 2006-02-10 03:50:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
Description is only partial above...

I'm trying to get FC5Test2 installed on a laptop for testing however the installer will not get to the point of bringing up the install "text" interface, saying what modules are being loaded.. ie USB interfaces. Then do nothing.
Out on the debug messages screen ctrl-F3 the last message to appear is "mounting cdrom  /dev/hdc" 
I'm not able to perform a media check from the laptop either.
I've tried doing a "linux askmethod" boot to use an FTP install but the installer even though the network device is detected and it seems to send out the DHCP request. There immediatley appears some garbage characters in the "determining IP address" popup and never gets the IP info. If you try to enter IP's manually the next window apears for connecting to the FTP repository etc. But fails to connect. looking at debug messages etc seems to show that at one point the network card went offline....

Anyway.  I know that there is nothing wrong with the CD, tried it on other systems and it worked fine.  Media check and install.. The ftp repository is also fine.

The laptop is a Dell Inspiron 9300...
has a Broadcom BCM4401-B0 network card..

I've previously installed FC3 on this laptop without any difficulties.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Paul Nasrat 2006-02-10 11:22:21 EST
What actual message does it show, is there something on tty3 (alt +f3) like:

moving (1) to step accounts
moving (1) to step reposetup
Warning, could not load sqlite, falling back to pickle

also check tty4 (alt + F4) for OOM killer message when it hangs.

I'm pretty sure you are experiencing bug #176492 and that will confirm it for me.
Comment 2 Richard Tresidder 2006-02-11 05:53:57 EST
Hi again.

For a straight "Enter" install 
TTY3 gives
 .....
  inserted /tmp/ieee1394.ko
  inserted /tmp/ohci1394.ko
  load module set done
  probing for firewire scsi devices
  modules to insert pcmcia_core yenta_core pcmcia
  load module set done
  modules to insert mii b44 yenta_socket libata ahci
  loaded mii from /modules/modules.cgz
  loaded b44 from /modules/modules.cgz
  loaded libata from /modules/modules.cgz
  loaded ahci from /modules/modules.cgz
  inserted /tmp/mii.ko
  inserted /tmp/b44.ko
  inserted /tmp/libata.ko
  inserted /tmp/ahci.ko
  load module set done
  trying to mount CD device hdc
no more messages..

TTY4
......
  eth0: Broadcomm 4400 10/100BaseT Ethernet 00:76:.. (MAC)
  libata version 1.20 loaded
  ahci 0000:00:1f.2: version 1.2
  ACPI: PCI Interrupt 0000:00:1f.2[B] - > Link [LINKB] -> GSI 5 (level, low) -> IRQ5
  ACPI: PCI Interrupt for device 0000:00:1f.2 disabled
  ahci: probe of 0000:00:1f.2 failed with error -12
  hdc: lost interrupt
  hdc: lost interrupt
  hdc: lost interrupt
  ide-cd: cmd 0x1e timed out
  hdc: lost interrupt
  repeats...


Turning ACPI off  ie "linux acpi=off" does not improve the situation. you still
get the ahci probe failure followed by the lost interrupts as above.

When doing a network install "linux askmethod" and selecting ftp.
we get through to the selection of language. 
on TTY3 the message saying   "trying to mount CD device hdc"
does not appear as before.
After getting to the point of selecting th IP information, I select DHCP and set
it off, however the information is not retrieved.
TTY3
  continuing from after "inserted /tmp/ahci.ko"
  load module set done
  setting language to en_US.UTF-8
  53 keympas are available
  need to set up networking
  going to pick an interface
  only have one network device: eth0    (odd the wirless device isn't found)
  going to do getNetConfig
  eth0 isn't a wireless adaptor
  running dhcp for eth0

TTY4
  irq9: nobody cared (try booting with "irqpoll" option)
  [<c01368a5>] __report_bad_irq+0x2b/0x69 [<c0136969>] note_interrupt+0x6d/0xa0
  [<c01363cd>] do_IRQ+0x9a/0xcd [<c0010548d>] do_IRQ+0x69/0x77
  [<c0103c9a>] common_interrupt+0x1a/0x20 [<c01362fe>] handle_IRQ_event+0x17/0x4c
  [<c01363ad>] do_IRQ+0x7a/0xcd [<c00105480>] do_IRQ+0x5c/0x77
  [<c0103c9a>] common_interrupt+0x1a/0x20 [<c01362fe>] gen_new_estimator+0x5d/0x15d

  more of the same.. including "do_softirq" messages
  inode_has_perm

  Disabling IRQ #9 appears on last line....   

OK now there is a hint... I tried doing the network install with the irqpoll
kernel option and the network worked :)
HOWEVER the normal install still failed on trying to mount the cdrom..

I have to go out for dinner now I will continue to finish the installation later.

I think this still needs to remain open to solve the normal install issue

Thanks
    Richard



Comment 3 Richard Tresidder 2006-02-11 05:57:19 EST
Hmm  quickly filled out the login info to see how much further it would go...
and after filling out login info and saying continue, the installer stopped again..

The same maessage appears on TTY3 
  trying to mount CD device hdc

on TTY4 we get 
  lost interrupt

OK no time to try anything else at the moment will get back later
Comment 4 Richard Tresidder 2006-02-11 10:54:11 EST
Done some more reading and this appears to be a rather widespread issue, and
seems to be assosciated with changes that were made to the acpi code
However I haven't been able to look much further than that 

I booted into the older FC3 installation on this laptop to get model info etc
from the cdrom.
The kernel used for this was 2.6.11-1.14_FC3 and the CDROM works but the network
interface won't. previously 2.6.9-1.667 kernel both CDROM and network were fine

CDROM is a    NEC DVD+/-RW ND-6500A
I'm unable to set DMA to on with this drive... comes back with operation not
permitted.. hmm


I have tried burning the install CD at 1x and the install still fails at the
same spot.
I've tried lots of different combinations with regard to dma and apic settings
such as off, noirq etc and nothing changes the situation,  I'd really like to
get this going for obvious reasons and it is frustrating that this is obviously
a regression of some sort

Thanks
  Richard
Comment 5 Richard Tresidder 2006-02-12 08:22:47 EST
Hi
   I've managed to find a possible kernel trap discussion on this
http://kerneltrap.org/node/5836

I have tried using the libata.atapi_enabled=1 as a boot parameter but it will
not work

It would be REALLY nice if TTY2 was up and actually working at this point so you
could do some manual fishing around.

I've tried using the noprobe boot parameter option to enable manual loading of
the drivers, however I can't seem to find any reference to libata in the driver
list. Using the noprobe option does bring tty2 up but the instant you enter a
command it locks the terminal....

Thanks
    Richard
Comment 6 Richard Tresidder 2006-02-28 03:42:44 EST
This problem does not exist in FC5 Test 3 anymore.
Everything seems to get probed correctly so I think this can be closed.
(well at least for this Dell inspiron 9300 system)

Thanks
   Richard
Comment 7 Richard Tresidder 2006-02-28 22:31:32 EST
OK maybe not fully solved...
Although a straight CD install will work fine,  Trying a network install will
not bring up the network card correctly.
However using the kernel config option "irqpoll" will get around this.
Seems that without this option we are still seeing irq9 being disabled.

So maybe don't close this yet, but I'm not sure how I can help debug this?

Thanks
    Richard
Comment 8 Dave Jones 2006-03-06 11:41:53 EST
please file a seperate bug for the networking problem. multiple problems in one
bug causes all kinds of confusion especially when searching for bugs.

Note You need to log in before you can comment on or make changes to this bug.