Bug 1807858 - "openshift_console_operator_build_info" is not exposed for console-operator
Summary: "openshift_console_operator_build_info" is not exposed for console-operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1806787
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 11:38 UTC by Jakub Hadvig
Modified: 2020-05-04 11:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:43:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 390 0 None open [release-4.4] Bug 1807858: Expose openshift_console_operator_build_info metric 2020-03-05 14:20:36 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:19 UTC

Description Jakub Hadvig 2020-02-27 11:38:31 UTC
This bug was initially created as a copy of Bug #1806787

I am copying this bug because: 



Description of problem:
This bug is from https://bugzilla.redhat.com/show_bug.cgi?id=1798315#c11
`openshift_console_operator_build_info` metrics should be expoosed for the console-operator, but it is not

# oc get pod -n openshift-console-operator
NAME                                READY   STATUS    RESTARTS   AGE
console-operator-75cb66d64d-sqdd4   1/1     Running   5          19h

# oc get ep -n openshift-console-operator
NAME      ENDPOINTS          AGE
metrics   10.129.0.13:8443   19h

# token=`oc sa get-token prometheus-k8s -n openshift-monitoring`
# oc -n openshift-console-operator exec console-operator-75cb66d64d-sqdd4 -- curl -k -H "Authorization: Bearer $token" 'https://10.130.0.15:8443/metrics'  | grep "openshift_console_operator_build_info"
no result

NOTE: Check all the metrics collected by Prometheus by followings, there is not `openshift_console_operator_build_info` metrics either
# token=`oc sa get-token prometheus-k8s -n openshift-monitoring`
# oc -n openshift-monitoring exec -c prometheus prometheus-k8s-0 -- curl -k -H "Authorization: Bearer $token" 'https://prometheus-k8s.openshift-monitoring.svc:9091/api/v1/label/__name__/values'  | jq




Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-24-020331

How reproducible:
Always

Steps to Reproduce:
1. See the description
2.
3.

Actual results:
"openshift_console_operator_build_info" is not exposed for console-operator

Expected results:
"openshift_console_operator_build_info" exposed for console-operator

Additional info:

Comment 1 bpeterse 2020-03-05 04:24:46 UTC
cherry-pick opened
https://github.com/openshift/console-operator/pull/390

Comment 4 shahan 2020-03-06 04:49:21 UTC
[hasha@fedora_pc ~/jenkins_trigger]$ oc -n openshift-console-operator exec console-operator-587679fc64-5td52 -- curl -k -H "Authorization: Bearer $token" 'https://10.128.0.39:8443/metrics'  | grep "openshift_console_operator_build_info"
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 46500    0 46500    0     0   367k      0 --:--:-- --:--:-- --:--:--  369k
# HELP openshift_console_operator_build_info [ALPHA] A metric with a constant '1' value labeled by major, minor, git commit & git version from which OpenShift Console Operator was built.
# TYPE openshift_console_operator_build_info gauge
openshift_console_operator_build_info{gitCommit="d559a43",gitVersion="",major="",minor=""} 1
4.4.0-0.ci-2020-03-06-033233

Comment 6 errata-xmlrpc 2020-05-04 11:43:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.