Bug 1807861 - Topology drag operations should indicate drop status on targets
Summary: Topology drag operations should indicate drop status on targets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1807204
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 11:49 UTC by Jeff Phillips
Modified: 2020-05-04 11:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1807204
Environment:
Version: 4.4.0-0.nightly-2020-02-12-235629 Cluster ID: 7b488325-fb3f-480c-8002-796ccbe49815 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
Last Closed: 2020-05-04 11:43:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification of bug 1807861 on 4.4 release (7.23 MB, image/gif)
2020-03-03 15:28 UTC, Abhishek K N
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4525 0 None closed [release-4.4] Bug 1807861: Update cursor to show drop status over targets 2020-04-28 20:24:17 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:19 UTC

Description Jeff Phillips 2020-02-27 11:49:01 UTC
+++ This bug was initially created as a clone of Bug #1807204 +++

Description of problem:

The cursor should be modified to:

Show the `Add` cursor better at all scales, it's hard to see the `+` even at 1:1 scale
Show a tooltip when over a valid add drop target informing the user that dropping will add an application here (after the standard delay without a mouse move)
Show an invalid drop cursor when over items where a drop would do nothing

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. From topology, drag the create connector over targets
2. Drag an existing connector over targets

Actual results:

The cursor gives no indication of drop status

Expected results:

Show the `Add` cursor better at all scales, it's hard to see the `+` even at 1:1 scale
Show a tooltip when over a valid add drop target informing the user that dropping will add an application here (after the standard delay without a mouse move)
Show an invalid drop cursor when over items where a drop would do nothing


Additional info:

Comment 3 Gajanan More 2020-03-03 13:20:33 UTC
I have validated this bug on
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 4 Abhishek K N 2020-03-03 15:28:48 UTC
Created attachment 1667213 [details]
Verification of bug 1807861 on 4.4 release

Comment 5 Abhishek K N 2020-03-03 15:29:25 UTC
On initiating Drag operations in topology, the cursor

1. Shows the `Add` cursor better at all scales
2. On staying over a drop target for resource creation for 2 seconds, the tooltip displays ‘Add Resources’.
3. For connectors, the tooltip appears the moment user hovers over a valid drop target.
4. Shows an invalid drop cursor when over items where a drop would do nothing

Verified build: 4.4.0-0.ci-2020-03-03-033811
Verified on Browsers: Chrome Version 80.0.3987.122 (Official Build) (64-bit), Safari Version 13.0.5 (14608.5.12)

Comment 7 errata-xmlrpc 2020-05-04 11:43:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.