Bug 18079 - installer dies when attempting to install packages
Summary: installer dies when attempting to install packages
Status: CLOSED DUPLICATE of bug 18032
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-02 13:04 UTC by George Avrunin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 13:04:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Avrunin 2000-10-02 13:04:10 UTC
Installing 7.0 as a new install on a system that had been running
6.1, I designated the / and /usr partitions to be reformatted 
(leaving /home alone).  After formatting those partitions, the
installer died when getting ready to install packages.  The
error window said to report this as a bug.  Here's the trace
from Anaconda that was saved to a floppy:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

The machine is a Dell XPS with a 500 MHz Pentium III, a 20 GB disk
(more or less; I'm not at the machine right now) with a 5 GB Windows
partition, and 384 MB of RAM.  It has an ATAPI CDROM drive and a 
SCSI CD-RW drive.  I wrote the CD with the CD-RW drive; the 
checksums on the .iso verified correctly and the CD seems to be
OK.

Please let me know if you need more information about the machine.

Comment 1 Alan Cox 2000-10-02 13:58:44 UTC

*** This bug has been marked as a duplicate of 18032 ***


Note You need to log in before you can comment on or make changes to this bug.