Bug 1808006 - ServiceBindingRequest with multiple backing services doesn't show connector in topology
Summary: ServiceBindingRequest with multiple backing services doesn't show connector i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On: 1808005
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 16:10 UTC by cvogt
Modified: 2020-05-04 11:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1808005
Environment:
Last Closed: 2020-05-04 11:43:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4533 0 None closed [release-4.4] Bug 1808006: support multiple service binding request backingServiceSelectors 2020-07-09 15:56:44 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:31 UTC

Description cvogt 2020-02-27 16:10:18 UTC
+++ This bug was initially created as a clone of Bug #1808005 +++

Description of problem:
ServiceBindingRequest with multiple backing services doesn't show connector in topology. The schema is changing from a single backing service to an array.


How reproducible:


Steps to Reproduce:
1. Install Service Binding Operator
2. follow example as in https://github.com/redhat-developer/service-binding-operator/tree/master/examples/multiple_services to create SBR with multiple backing services

Actual results:
No SBR connector shows up in the topology.

Expected results:
An SBR connector shows up in topology.


Additional info:
Requires installation of service binding operator with latest schema or for testing simply update the CRD of the service binding request.

Comment 3 Jaivardhan Kumar 2020-03-05 12:41:39 UTC
Have verified with `0.1.0-251` still operatorHub has `0.0.24-214` so need source manually latest release of SBO with below

```
apiVersion: operators.coreos.com/v1
kind: OperatorSource
metadata:
  name: avni-operators
  namespace: openshift-marketplace
spec:
  type: appregistry
  endpoint: https://quay.io/cnr
  registryNamespace: redhat-developer
```

Verified 4.4


```
OpenShift Version
4.4.0-0.nightly-2020-03-05-014624
Kubernetes Version
v1.17.1
Channel
stable-4.4
Cluster ID
714860d8-af7b-4390-9294-ba71303cf80b
API Server
https://api.gamore44installer0503.devcluster.openshift.com:6443
```

Comment 5 errata-xmlrpc 2020-05-04 11:43:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.