Bug 1808018 - On Baremetal platform CRI-O often binds its streaming port on unsuitable addresses
Summary: On Baremetal platform CRI-O often binds its streaming port on unsuitable add...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Antoni Segura Puimedon
QA Contact: Nataf Sharabi
URL:
Whiteboard:
Depends On:
Blocks: 1807998
TreeView+ depends on / blocked
 
Reported: 2020-02-27 16:23 UTC by Antoni Segura Puimedon
Modified: 2020-07-13 17:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Multiple available networks on worker nodes make it difficult to pick an address on the control plane for CRI-O. Consequence: CRI-O often binds to a non control plane interface Fix: Make CRI-O systemd service depend on a service that chooses the right interface and configures the CRI-O service. Result: CRI-O binds to an address in the control plane.
Clone Of: 1807998
Environment:
Last Closed: 2020-07-13 17:21:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1509 None closed CRI-O to set stream address in ctrl plane 2020-07-06 17:46:40 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:22:13 UTC

Description Antoni Segura Puimedon 2020-02-27 16:23:45 UTC
+++ This bug was initially created as a clone of Bug #1807998 +++

Description of problem:
On Baremetal, and specially on IPv6 deploymnets, CRI-O's default setting of stream-address="" makes it bind to whichever address. That means that it can easily end up on the provisioning network.

How reproducible: Often


Steps to Reproduce:
1. Trigger a baremetal deployment
2. ssh to the different nodes
3. sudo ss -lptn | grep crio

Actual results:
Binds to provisioning network or some address not in the control plane.


Expected results:
Should be bound to a non VIP address on the control plane network (non-deprecated, non-link-local IPv6 address when IPv6 deployment).

Additional info:
You can check if crio got a stream address specified with a short command like in this example:

[core@master-0 ~]$ cat "/proc/$(pgrep crio)/cmdline" | xargs -0 echo
/usr/bin/crio --stream-address=fd2e:6f44:5dd8:c956::14 --enable-metrics=true --metrics-port=9537

Comment 3 errata-xmlrpc 2020-07-13 17:21:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.