Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1808145 - Address QoL Items For Pipeline Builder
Summary: Address QoL Items For Pipeline Builder
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1808144
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 23:06 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1808144
Environment:
Last Closed: 2020-05-04 11:43:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Address QoL Items For Pipeline Builder (568.20 KB, video/webm)
2020-03-03 08:31 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4564 0 None closed [release-4.4] Bug 1808145: Pipeline builder ux changes 2020-05-01 14:14:00 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:33 UTC

Description Andrew Ballantyne 2020-02-27 23:06:28 UTC
+++ This bug was initially created as a clone of Bug #1808144 +++

Description of problem:
There are a few tiny issues that could still be improved in the Pipeline Builder.

- Modal content needs to be written by UX
- Deleting a List Task is not possible right now
- Selection between two tasks is quite annoying, requiring the sidebar to closer first before another task can be selected
- Deleting a task that has an error locks the form from being submitted

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Navigate to the "Create Pipeline" button on the Pipelines page and enter the Pipeline Builder
2. Try any of the steps above

Actual results:
A diminished experience

Expected results:
A better experience

Additional info:

Comment 3 Ruchir Garg 2020-03-02 06:38:30 UTC
Bulk assigning all to Gajanan for verification.

Comment 4 spathak@redhat.com 2020-03-03 08:31:09 UTC
Verified on build : 4.4.0-0.ci-2020-03-01-110146
Chrome browser: 76.0.3809.132

Comment 5 spathak@redhat.com 2020-03-03 08:31:50 UTC
Created attachment 1667138 [details]
Address QoL Items For Pipeline Builder

Comment 7 errata-xmlrpc 2020-05-04 11:43:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.