Bug 1808150 - neither pciutils-devel or pciutils include the pcilib manpage
Summary: neither pciutils-devel or pciutils include the pcilib manpage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pciutils
Version: 31
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 00:33 UTC by Jacob Keller
Modified: 2020-03-17 01:35 UTC (History)
1 user (show)

Fixed In Version: pciutils-3.6.4-1.fc30 pciutils-3.6.4-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-17 01:35:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Jacob Keller 2020-02-28 00:33:10 UTC
Description of problem:
Neither the pciutils or pciutils-devel package for Fedora 31 seem to include the pcilib.7 man page.

Version-Release number of selected component (if applicable):
pciutils-3.6.2-3.fc31.x86_6
pciutils-devel-3.6.2-3.fc31.x86_64

How reproducible:
Always

Steps to Reproduce:
1. man 7 pcilib

Actual results:
man page is not found

Expected results:
the pcilib man page should be found.


Additional info:
the lspci man page indicates to read pcilib(7) for some further information. The upstream pciutils project includes a manual page for pcilib.

I would expect pcilib.7.gz to be installed by at least pciutils-devel, if not pciutils itself, especially since the lspci manual page mentions it.

Comment 1 Fedora Update System 2020-02-29 03:11:43 UTC
pciutils-3.6.4-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-875081b2ba

Comment 2 Fedora Update System 2020-03-17 01:35:56 UTC
pciutils-3.6.4-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.