Bug 1808154
| Summary: | Failed to create VDO with hc deployment wizard | ||
|---|---|---|---|
| Product: | [oVirt] cockpit-ovirt | Reporter: | SATHEESARAN <sasundar> |
| Component: | gluster-ansible | Assignee: | Gobinda Das <godas> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | SATHEESARAN <sasundar> |
| Severity: | urgent | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 0.14.1 | CC: | bugs, michal.skrivanek, mwaykole, rhs-bugs, sabose, sasundar |
| Target Milestone: | ovirt-4.4.0 | Flags: | sbonazzo:
ovirt-4.4?
sbonazzo: planning_ack? sbonazzo: devel_ack+ sasundar: testing_ack+ |
| Target Release: | --- | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | cockpit-ovirt-0.14.3 | Doc Type: | If docs needed, set a value |
| Doc Text: | Story Points: | --- | |
| Clone Of: | 1808081 | Environment: | |
| Last Closed: | 2020-05-20 20:02:29 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | Gluster | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | |||
| Bug Blocks: | 1808081 | ||
Tested with cockpit-ovirt-dashboard-0.14.3 vdo volumes could be created successfully with the following steps: 1. Use RHVH 4.4 based on RHEL 8.2 2. Start HC deployment using cockpit wizard. 3. Select 'Enable dedupe and compression' on the brick Deployment was successful. This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020. Since the problem described in this bug report should be resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |
Description of problem: ----------------------- Hyperconverged deployment wizard failed to create vdo as VDO readcache is not supported with VDO in RHEL-8 Version-Release number of selected component (if applicable): ------------------------------------------------------------- gluster-ansible-infra-1.0.4-4.el8rhgs.noarch gluster-ansible-cluster-1.0-1.el8rhgs.noarch gluster-ansible-repositories-1.0.1-2.el8rhgs.noarch gluster-ansible-features-1.0.5-4.el8rhgs.noarch gluster-ansible-roles-1.0.5-5.el8rhgs.noarch gluster-ansible-maintenance-1.0.1-1.el8rhgs.noarch cockpit-ovirt-dashboard-0.14.1-1.el8ev.noarch vdo-6.2.2.117-13.el8.x86_64 kmod-kvdo-6.2.2.117-63.el8.x86_64 How reproducible: ------------------ Always Steps to Reproduce: -------------------- 1. Start a hyperconverged deployment from cockpit HC wizard Actual results: ---------------- Deployment fails at VDO creation step Expected results: ----------------- Deployment should be successful Additional info: ------------------ failed: [node.example.com] (item={'name': 'vdo_sdc', 'device': '/dev/sdc', 'slabsize': '32G', 'logicalsize': '10000G', 'blockmapcachesize': '128M', 'emulate512': 'off', 'writepolicy': 'auto'}) => { "ansible_loop_var": "item", "changed": false, "err": "usage: vdo create [-h] -n <volume> --device <devicepath>\n [--activate {disabled,enabled}]\n [--blockMapCacheSize <megabytes>]\n [--blockMapPeriod <period>]\n [--compression {disabled,enabled}]\n [--deduplication {disabled,enabled}]\n [--emulate512 {disabled,enabled}] [--force]\n [--indexMem <gigabytes>] [--maxDiscardSize <megabytes>]\n [--sparseIndex {disabled,enabled}] [--uuid <uuid>]\n [--vdoAckThreads <threadCount>]\n [--vdoBioRotationInterval <ioCount>]\n [--vdoBioThreads <threadCount>]\n [--vdoCpuThreads <threadCount>]\n [--vdoHashZoneThreads <threadCount>]\n [--vdoLogicalSize <megabytes>]\n [--vdoLogicalThreads <threadCount>]\n [--vdoLogLevel {critical,error,warning,notice,info,debug}]\n [--vdoPhysicalThreads <threadCount>]\n [--vdoSlabSize <megabytes>]\n [--writePolicy {async,async-unsafe,sync,auto}] [-f <file>]\n [--logfile <pathname>] [--verbose]\nvdo create: error: unrecognized arguments: --readCacheSize=0\n", "invocation": { "module_args": { "ackthreads": "1", "activated": true, "biothreads": "4", "blockmapcachesize": "128M", "compression": "enabled", "cputhreads": "2", "deduplication": null, "device": "/dev/sdc", "emulate512": false, "growphysical": false, "indexmem": "0.25", "indexmode": "dense", "logicalsize": "10000G", "logicalthreads": "1", "name": "vdo_sdc", "physicalthreads": "1", "readcache": "disabled", "readcachesize": "0", "running": true, "slabsize": "32G", "state": "present", "writepolicy": "auto" } }, "item": { "blockmapcachesize": "128M", "device": "/dev/sdc", "emulate512": "off", "logicalsize": "10000G", "name": "vdo_sdc", "slabsize": "32G", "writepolicy": "auto" }, "msg": "Creating VDO vdo_sdc failed.", "rc": 2 } NO MORE HOSTS LEFT *************************************************************************************************************************************************************************** PLAY RECAP **********************************************************************************************************************