Bug 1808280 - Deploy Image: "Image name from internal registry" with Knative Service creates a broken ImageStream
Summary: Deploy Image: "Image name from internal registry" with Knative Service create...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1808282
TreeView+ depends on / blocked
 
Reported: 2020-02-28 06:59 UTC by Jaivardhan Kumar
Modified: 2020-05-04 11:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: In case of Container image deployment if internal image stream sis selected for knative then as well it tries to create new Image Stream and thus may fail Consequence: Unable to deploy image (internal image stream) as knative service Fix: Don create new Image Stream for internal image selection as it already exists. Result: Able to deploy as knative service for internal image registry
Clone Of:
: 1808282 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:43:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Deploy Image: "Image name from internal registry" with Knative Service doesn't creates a broken ImageStream (127.74 KB, image/png)
2020-02-28 16:33 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:43:33 UTC

Description Jaivardhan Kumar 2020-02-28 06:59:05 UTC
Description of problem: In Deploy Image select"Image name from internal registry" with with stream of image created via gitImport flow with Knative Service and it'll fail to deploy as creates a broken ImageStream


Version-Release number of selected component (if applicable):4.3


How reproducible: Always


Steps to Reproduce:
1.Install Serverless operator
2.Create a new Project 'app-test'
3.Move to DevConsole -> Click on Git Import -> import any image with deployment selection
4. Wait for above build to complete
5. Click on Add -> Container Image -> Select imageStream created as part of step 3 and Select Knative Service. 


Actual results: Deployment for knative Service will fail


Expected results: Deployment for knative Service should pass


Additional info:

Comment 3 spathak@redhat.com 2020-02-28 16:33:01 UTC
Created attachment 1666441 [details]
Deploy Image: "Image name from internal registry" with Knative Service doesn't creates a broken ImageStream

Comment 4 spathak@redhat.com 2020-02-28 16:34:21 UTC
Verified on build : 4.4.0-0.ci-2020-02-26-215902
Chrome browser: 76.0.3809.132

Comment 6 errata-xmlrpc 2020-05-04 11:43:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.