Bug 1808338 - [DR]backup failure: cp: cannot stat '/etc/kubernetes/manifests/etcd-member.yaml': No such file or directory
Summary: [DR]backup failure: cp: cannot stat '/etc/kubernetes/manifests/etcd-member.ya...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.4.z
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 09:44 UTC by ge liu
Modified: 2020-06-17 22:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-17 22:26:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2445 0 None None None 2020-06-17 22:26:28 UTC

Description ge liu 2020-02-28 09:44:52 UTC
Description:

#  sudo /usr/local/bin/etcd-snapshot-backup.sh ./assets/mybackup
Creating asset directory ./assets
9db866252781ab60d0d2c34d57936e09457fac0c5e75365bc5b55ce006594769
etcdctl version: 3.3.18
API version: 3.3
Trying to backup etcd client certs..
etcd client certs found in /etc/kubernetes/static-pod-resources/kube-apiserver-pod-12 backing up to ./assets/backup/
Backing up /etc/kubernetes/manifests/etcd-member.yaml to ./assets/backup/
cp: cannot stat '/etc/kubernetes/manifests/etcd-member.yaml': No such file or directory
sh-4.4# 

4.4.0-0.nightly-2020-02-27-020932

Description of problem:

etcd backup failure.

How reproducible:
Always

Steps to Reproduce:



Actual results:

Expected results

Comment 1 ge liu 2020-02-28 09:45:49 UTC
sh-4.4# cd assets/
sh-4.4# ls
backup	bin  manifests	mybackup  restore  shared  templates  tmp
sh-4.4# cd mybackup/
sh-4.4# ls
sh-4.4#

Comment 3 ge liu 2020-03-03 08:45:40 UTC
Hi Sruesh, yes, Verified with 4.4.0-0.nightly-2020-03-03-033819, thanks!

Comment 9 errata-xmlrpc 2020-06-17 22:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445


Note You need to log in before you can comment on or make changes to this bug.