Bug 1808410 - Call connection failure
Summary: Call connection failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libnice
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Stefan Becker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 12:45 UTC by Brian J. Murrell
Modified: 2020-03-16 20:30 UTC (History)
6 users (show)

Fixed In Version: libnice-0.1.16-8.fc30 libnice-0.1.16-8.fc31 libnice-0.1.16-8.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-08 00:08:32 UTC
Type: Bug


Attachments (Terms of Use)
Upstream merged request rebased to Fedora code base (7.62 KB, patch)
2020-02-28 18:28 UTC, Stefan Becker
no flags Details | Diff
patch (7.14 KB, text/plain)
2020-02-28 18:29 UTC, Brian J. Murrell
no flags Details
patch (1.45 KB, application/mbox)
2020-02-28 18:40 UTC, Brian J. Murrell
no flags Details
Fix incorrectly ignored interfaces (1/2) (847 bytes, patch)
2020-02-28 20:03 UTC, Stefan Becker
no flags Details | Diff
Fix incorrectly ignored interfaces (2/2) (1.83 KB, patch)
2020-02-28 20:06 UTC, Stefan Becker
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
freedesktop.org Gitlab libnice/libnice - merge_requests 90 0 None None None 2020-02-28 17:01:09 UTC
freedesktop.org Gitlab libnice libnice issues 99 0 None None None 2020-02-28 17:01:09 UTC

Description Brian J. Murrell 2020-02-28 12:45:29 UTC
Description of problem:
Pidgin-SIPE calls fail to connect.

Version-Release number of selected component (if applicable):
0.1.16-3

How reproducible:
100%

Steps to Reproduce:
N/A

Actual results:
Calls fail to connect and sit in Calling state indefinitely.

Expected results:
Calls should connect.

Additional info:
A patch upstream: https://gitlab.freedesktop.org/libnice/libnice/-/merge_requests/90 has been tested locally against the 0.16.3 libnice RPM to rectify the problem.

I have also asked about a newer libnice release, including the above patch at least, in https://gitlab.freedesktop.org/libnice/libnice/issues/106.

Comment 1 Kamil Dudka 2020-02-28 13:12:09 UTC
Thanks!  Let's wait to see whether a new release is planned.  If not, we will pick the mentioned change only.

Comment 2 Stefan Becker 2020-02-28 17:31:26 UTC
Patch as such doesn't apply, needs rebase for our code base

Comment 3 Stefan Becker 2020-02-28 18:28:37 UTC
Created attachment 1666459 [details]
Upstream merged request rebased to Fedora code base

Can reporter please confirm that this rebased patch fixes his issue?

Comment 4 Brian J. Murrell 2020-02-28 18:29:04 UTC
Created attachment 1666460 [details]
patch

Indeed.  I'll attach my attempt (works at least) at resolving the merge conflicts.

Comment 5 Brian J. Murrell 2020-02-28 18:40:50 UTC
Created attachment 1666461 [details]
patch

FWIW, I also have this patch in my local build.

Comment 6 Brian J. Murrell 2020-02-28 19:25:28 UTC
I've tested https://src.fedoraproject.org/rpms/libnice/blob/f30/f/libnice.spec + attachment #1666459 [details] and it does not work.  There must be something in https://src.fedoraproject.org/rpms/libnice/blob/f30/f/libnice-0.1.16-16-gb998547.patch that is not in attachment #1666461 [details] patch that is preventing the connection from completing.

Comment 7 Stefan Becker 2020-02-28 19:46:28 UTC
(In reply to Brian J. Murrell from comment #6)
> There must be something in
> https://src.fedoraproject.org/rpms/libnice/blob/f30/f/libnice-0.1.16-16-gb998547.patch
> that is not in attachment #1666461 [details] patch that is preventing the connection from completing.

Actually I'm not surprised, because why would getifaddrs() fail on a normal Linux distro, i.e. why would that change fix your issue?

Taking and educated guess from the differences between my and your rebase I think the your issue is actually fixed by

  * https://gitlab.freedesktop.org/libnice/libnice/-/commit/bd4b47813844aa0e68e9074b3ac516c383ca8bab (from https://gitlab.freedesktop.org/libnice/libnice/-/merge_requests/66)
  * https://gitlab.freedesktop.org/libnice/libnice/-/merge_requests/107 (I just submitted that, because merge request !66 missed the 2nd spot)

Comment 8 Stefan Becker 2020-02-28 20:03:57 UTC
Created attachment 1666466 [details]
Fix incorrectly ignored interfaces (1/2)

Comment 9 Stefan Becker 2020-02-28 20:06:23 UTC
Created attachment 1666467 [details]
Fix incorrectly ignored interfaces (2/2)

Two upstream patches that fix the issue of the first ignored interface causing all further interfaces to be ignored.

Comment 10 Brian J. Murrell 2020-02-28 20:41:53 UTC
Given the number of patches we are talking about now and the ease of confusion here, would it be easy enough for you to do a scratch build (koji/bodhi or whatever that all is) of a libnice that includes all of the patches you want me to test?

Comment 11 Stefan Becker 2020-02-28 21:05:46 UTC
(In reply to Brian J. Murrell from comment #10)
> would it be easy enough for you to do a scratch build

https://koji.fedoraproject.org/koji/taskinfo?taskID=41997034

Comment 12 Brian J. Murrell 2020-02-28 21:13:10 UTC
Yeah, that works.  Yay!  Thanks much!

Comment 13 Fedora Update System 2020-02-28 21:39:04 UTC
FEDORA-2020-0873b72ac7 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0873b72ac7

Comment 14 Fedora Update System 2020-02-28 21:39:46 UTC
FEDORA-2020-99df8540a8 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-99df8540a8

Comment 15 Fedora Update System 2020-02-29 01:22:47 UTC
libnice-0.1.16-8.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-107faf279e

Comment 16 Fedora Update System 2020-02-29 03:11:51 UTC
libnice-0.1.16-8.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-0873b72ac7

Comment 17 Fedora Update System 2020-02-29 04:00:02 UTC
libnice-0.1.16-8.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-99df8540a8

Comment 18 Kamil Dudka 2020-03-02 08:44:25 UTC
Thank you for fixing it, Stefan!

Comment 19 Fedora Update System 2020-03-08 00:08:32 UTC
libnice-0.1.16-8.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2020-03-08 00:51:23 UTC
libnice-0.1.16-8.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2020-03-16 20:17:38 UTC
libnice-0.1.16-8.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2020-03-16 20:30:13 UTC
libnice-0.1.16-8.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.