Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1808439 - Packages are missing from CCV when CVs have same repository with different include filters
Summary: Packages are missing from CCV when CVs have same repository with different in...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: James Jeffers
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 14:32 UTC by Manu Sunil
Modified: 2020-08-21 21:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-09 13:12:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Manu Sunil 2020-02-28 14:32:42 UTC
Description of problem:

 - Packages are missing from CCV when component CVs contain same repositories with include filters for some packages.

Version-Release number of selected component (if applicable):

 - Satellite 6.6

How reproducible:


Steps to Reproduce:

 - Create two CVs
 - Add the same repository to both the CVs
 - Create a filter for including one package in the CV1 and publish the CV
 - Similarly, create a filter for a different package in CV2 and publish it as well


Actual results:

 - The results depend on the way in which the CCV published after adding the content_views
 - If CV1 is added to the CCV and published before CV2 is added, only included packages from CV1 is available in CCV
 - Similarly, if CV2 is added and CCV is published before CV1 is added, only included packages from CV2 is available in the CCV
 - If both are added together and CCV is published, none of the packages are available in the CCV

Expected results:

- All the included packages from both the CV should be available on the CCV

Comment 4 James Jeffers 2020-05-07 11:20:44 UTC
Tested the scenarios in 6.7, and all repositories appeared in the composite view, regardless of the order in which the content views were added.

I'll back track between the 2 releases and triangulate where the issue was fixed.

Comment 5 James Jeffers 2020-05-08 20:06:27 UTC
I attempted to reproduce this scenario on a sat 6.6 install, and was unable to. Is there more context to this issue?

Comment 6 James Jeffers 2020-05-08 20:09:10 UTC
Information like which repository, filters used, etc would be helpful. Thanks!

Comment 8 James Jeffers 2020-05-22 14:54:52 UTC
Is it possible to get access to a reproducer for this issue. I'm not able to reproduce this condition with my local attempts.

Comment 10 James Jeffers 2020-05-29 16:31:46 UTC
Looked at the repodata and the published metadata (unzipped the filelist.xml.gz) for the CCV show no packages:

<filelists xmlns="http://linux.duke.edu/metadata/filelists" packages="0"></filelists>

Still investigating the cause.

Comment 11 James Jeffers 2020-06-01 16:06:32 UTC
After checking the published metadata and comparing to a known katello issue re yum distributors, a fix has been identified. 

Upgrading to Satellite 6.6.3 (with tfm-rubygem-katello-3.12.0.41-1.el7sat.noarch, etc is available) should resolve this issue. After the upgrade the CVs should be republished for the packages to appear as available to the content host.

See also: https://bugzilla.redhat.com/show_bug.cgi?id=1814426


Note You need to log in before you can comment on or make changes to this bug.