Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1808546 - The discover-etcd-initial-cluster tool should return no error if member dir exists, and cannot get client or target member
Summary: The discover-etcd-initial-cluster tool should return no error if member dir e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Suresh Kolichala
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1808544
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 19:15 UTC by Suresh Kolichala
Modified: 2020-05-04 11:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1808544
Environment:
Last Closed: 2020-05-04 11:43:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift etcd pull 37 0 None closed [openshift-4.4] Bug 1808546: If we weren't able to get client or target member go ahead and start 2020-03-20 06:49:53 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:44:08 UTC

Description Suresh Kolichala 2020-02-28 19:15:34 UTC
+++ This bug was initially created as a clone of Bug #1808544 +++

Description of problem:
In lights-out scenario (turn the lights off and on again scenario), the calls get client will return error. However, because discover-etcd-initial-cluster return error currently, etcd never gets to start.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn all the master nodes off on a running cluster.
2. Turn them back on.


Actual results:
etcd fails to come up. crictl logs show that discover-etcd-initial-cluster is returning error.

Expected results:
etcd, API server and rest of the cluster should be up.

Additional info:

Comment 5 errata-xmlrpc 2020-05-04 11:43:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.