Bug 1808564 - Wi-fi networks not displayed in F32 SoaS (works in F31 SoaS) spin
Summary: Wi-fi networks not displayed in F32 SoaS (works in F31 SoaS) spin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar
Version: 32
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-02-28 20:11 UTC by Alex Perez
Modified: 2020-03-10 01:56 UTC (History)
20 users (show)

Fixed In Version: sugar-0.116-5.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-10 01:56:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Alex Perez 2020-02-28 20:11:18 UTC
Description of problem: No wireless networks are detected in the 'neighborhood view' pane of Sugar, under Fedora 32. I suspect this is related to changes in NetworkManager. NetworkManager in F31 is version 1.20.10, and I've confirmed that the F31 SoaS image works as expected in this regard, on bare metal.


Version-Release number of selected component (if applicable): 


How reproducible: 100%


Steps to Reproduce:
1. Boot SoaS
2. Press F1
3. Note no wireless networks present, only the ad-hoc networks. 

Actual results: Only wireless ad-hoc networks listed, but I can manually connect to wi-fi networks with wpa_supplicant.


Expected results: List of wireless networks


Additional info:

Comment 1 Peter Robinson 2020-02-28 20:13:20 UTC
sugar-base doesn't exist any more.

Comment 2 Ibiam 2020-02-29 00:27:23 UTC
Peter can you change the component and assign this to me, thanks.

Comment 3 Peter Robinson 2020-02-29 00:37:46 UTC
This needs further investigation, it looks like a NM issue, not sure whether it's a regression or whether it's a deprecation that wasn't advertised to the sugar community.

Comment 4 Beniamino Galvani 2020-02-29 08:03:12 UTC
Do you see wifi networks in the output of 'nmcli device wifi'?

Comment 5 Alex Perez 2020-03-01 18:22:18 UTC
Executing 'nmcli device wifi' lists all wi-fi networks as expected, and shows that it's connected to "Ad-hoc network 1" by default, which is not desired/expected behavior.

These same networks don't show up on the Network Neighborhood Sugar page (F1), and therefore I suspect this is a NetworkManager API issue. Interestingly, the connected ad-hoc network 1 does not show as connected in the Sugar UI, either, and it should.

Comment 6 Fedora Update System 2020-03-03 18:43:55 UTC
FEDORA-2020-59fe8b4ca5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-59fe8b4ca5

Comment 7 Fedora Update System 2020-03-04 20:14:16 UTC
sugar-0.116-5.fc32, sugar-toolkit-gtk3-0.116-7.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-59fe8b4ca5

Comment 8 Alex Perez 2020-03-05 02:24:25 UTC
With FEDORA-2020-59fe8b4ca5 applied (now in the nightlies), this problem appears to be resolved, and wi-fi networks are detected, and usable.

Comment 9 Fedora Blocker Bugs Application 2020-03-05 09:48:04 UTC
Proposed as a Freeze Exception for 32-beta by Fedora user pbrobinson using the blocker tracking app because:

 Fixes displaying WiFi networks on the Sugar desktop/SoaS. Being able to connect to wifi using the GUI is useful :)

Comment 10 Adam Williamson 2020-03-07 18:56:46 UTC
+1 FE for me.

Comment 11 Geoffrey Marr 2020-03-10 01:04:27 UTC
Discussed during the 2020-03-09 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-09/f32-blocker-review.2020-03-09-16.01.txt

Comment 12 Fedora Update System 2020-03-10 01:56:18 UTC
sugar-0.116-5.fc32, sugar-toolkit-gtk3-0.116-7.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.