Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1808594 - There is no API endpoint to get details of a specific Helm Chart
Summary: There is no API endpoint to get details of a specific Helm Chart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1808524
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 21:53 UTC by Predrag Knezevic
Modified: 2020-05-04 11:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1808524
Environment:
Last Closed: 2020-05-04 11:43:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
Helm chart details (209.71 KB, image/png)
2020-03-04 12:25 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4563 0 None closed [release-4.4] Bug 1808594: added endpoint for retrieving details for the given Helm chart. 2020-04-22 13:58:20 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:44:08 UTC

Description Predrag Knezevic 2020-02-28 21:53:38 UTC
+++ This bug was initially created as a clone of Bug #1808524 +++

Description of problem:
In order to fix the experience around Helm installation, we need to have an API endpoint that returns all the details of a specific Helm chart.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Actual results:
There is no API to get chart details.

Expected results:
There should be an API that returns chat details.

Additional info:

Comment 3 Gajanan More 2020-03-04 12:25:24 UTC
Created attachment 1667477 [details]
Helm chart details

Comment 4 Gajanan More 2020-03-04 12:26:04 UTC
I have validated this bug on 
Build:4.4.0-0.nightly-2020-03-04-000622 
Browser:Google Chrome Version 78.0.3904.108
Marking this bug as verified

Comment 6 errata-xmlrpc 2020-05-04 11:43:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.