Bug 1808651 - Enable https://fedoraproject.org/wiki/Changes/PythonNoSemanticInterpositionSpeedup on power and arm
Summary: Enable https://fedoraproject.org/wiki/Changes/PythonNoSemanticInterpositionSp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python3
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32BetaFreezeException 1779341
TreeView+ depends on / blocked
 
Reported: 2020-02-29 09:08 UTC by Miro Hrončok
Modified: 2020-03-06 20:49 UTC (History)
14 users (show)

Fixed In Version: python3-3.8.2-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-06 20:49:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-02-29 09:08:34 UTC
The https://fedoraproject.org/wiki/Changes/PythonNoSemanticInterpositionSpeedup change was temporarily reverted on armv7hl and ppc64le, because of a gcc regression (bz1795575). The gcc regression was not marked fixed until after the beta freeze despite our efforts to get the gcc maintainers backport the fix in time.

Later, it was said that the regression is "fixed for almost a month".

The change required is done on rawhide and waiting in a reviewed Fedora 32 Pull request: https://src.fedoraproject.org/rpms/python3/pull-request/177

We are quite confident this should not break anything and the speedup benefits outweigh the risk of enabling this late.

Hence, I'm opening this to request a freeze exception.

Comment 1 Zbigniew Jędrzejewski-Szmek 2020-02-29 12:40:57 UTC
+1 for freeze exception

Comment 2 František Zatloukal 2020-03-02 12:06:16 UTC
+1 FE, the sooner we test it, the better.

Comment 3 Miro Hrončok 2020-03-02 12:09:34 UTC
If I am not here once the decision is made, aby provenpackager or python3 maintainer can just merge, build and create an update (and a buildroot override for koschei to test with). I'd use karma limits of +10,-2 because not a lot of people will test this on the affected architectures, but we get a lot of "LGTM" responses on python updates.

Comment 4 Lukas Brabec 2020-03-02 13:21:53 UTC
+1 FE

Comment 5 František Zatloukal 2020-03-02 13:23:11 UTC
Counting 3 times +1, marking as accepted FE.

Comment 6 Miro Hrončok 2020-03-02 13:25:08 UTC
Building.

Comment 7 Fedora Update System 2020-03-02 14:24:37 UTC
FEDORA-2020-456114363d has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-456114363d

Comment 8 Fedora Update System 2020-03-02 16:41:22 UTC
python3-3.8.2-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-456114363d

Comment 9 Fedora Update System 2020-03-06 20:49:14 UTC
python3-3.8.2-2.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.