Bug 1808668 - moose fails to build with Python 3.9: test_pyrun (SEGFAULT)
Summary: moose fails to build with Python 3.9: test_pyrun (SEGFAULT)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: moose
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1842097 1871501 (view as bug list)
Depends On:
Blocks: F33BetaFreezeException PYTHON39 F33FTBFS F33FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-02-29 10:06 UTC by Miro Hrončok
Modified: 2020-09-14 23:43 UTC (History)
8 users (show)

Fixed In Version: moose-3.1.5-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-14 23:43:49 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github BhallaLab moose-core issues 419 0 None closed Python 3.9: test_pyrun segfaults 2020-09-17 20:38:08 UTC

Internal Links: 1842097

Description Miro Hrončok 2020-02-29 10:06:55 UTC
moose fails to build with Python 3.9.0a4.

The following tests passed:
	test_function
	test_kkit
	test_ksolve
	test_moose_paths
	test_neuroml
	test_nsdf
	test_pymoose
	test_sbml
	test_snippets
	test_synchan
	test_table_streaming_support
	test_vec
92% tests passed, 1 tests failed out of 13
Total Test time (real) =   9.52 sec
The following tests FAILED:
	  8 - test_pyrun (SEGFAULT)
Errors while running CTest

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01259222-moose/

For all our attempts to build moose with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/moose/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-05-25 13:01:52 UTC
This comment is mass posted to all bugs blocking the Python 3.9 tracker, sorry if it is not 100 % relevant. When in doubt, please ask.


The Python 3.9 rebuild is in progress in a Koji side tag.

If you fix this bug, please don't rebuild the package in regular rawhide, but do it in the side tag with:

    $ fedpkg build --target=f33-python

The rebuild is progressing slowly and it is possible this package won't have all the required build dependencies yet. If that's the case, please just leave the fix committed and pushed and we will eventually rebuild it for you.

You are not asked to go and try rebuild all the missing dependencies yourself. If you know there is a bootstrap loop in the dependencies, let me know and we can untangle it together.

If you want to test your fix or reproduce the failure, you can still use the Copr repo mentioned in the initial comment of this bug: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Comment 2 Miro Hrončok 2020-05-29 07:11:46 UTC
Python 3.9 update: The f33-python side tag is currently being merged.

New builds in f33-python are no longer possible, but python3 is not yet updated to Python 3.9 in rawhide. You can check when Python is Python 3.9 with:

    $ koji wait-repo f33-build --build python3.9-3.9.0~b1-3.fc3

And build the packages normally after that.

Comment 3 Miro Hrončok 2020-06-10 10:40:55 UTC
*** Bug 1842097 has been marked as a duplicate of this bug. ***

Comment 4 Ben Cotton 2020-08-11 13:12:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 5 Miro Hrončok 2020-08-22 10:30:54 UTC
Hello. This comment is mass posted to all 16 bugzillas for packages that failed to rebuild with Python 3.9 (and, in most cases, also fail to install on Fedora 33 and 34). Apologies if some of the suggestions or questions don't apply 100%.

Fedora 33 Beta Freeze starts next week on Tuesday, 2020-08-25. I haven't spammed this bugzilla because it is in ASSIGNED, or I've seen upstream has been notified.

Please consider what to do here. Is this failure critical? For example, can a test be temporarily skipped to make this package build? Is it possible to fix or workaround the failure before Fedora 33 Beta? Or before Fedora 33 Final? If not, would it make sense to retire the package (even temporarily) before the release to unblock updates from Fedora 31 or Fedora 32?

In case you need any assistance with a Python-related problem with the build, don't hesitate to let me know and I'll try to have a look.

Thank you!

Comment 6 Miro Hrončok 2020-08-26 11:54:15 UTC
*** Bug 1871501 has been marked as a duplicate of this bug. ***

Comment 7 Ankur Sinha (FranciscoD) 2020-08-26 21:13:09 UTC
Currently building with the test disabled. Upstream has also been informed.

Comment 8 Fedora Update System 2020-08-27 10:44:07 UTC
FEDORA-2020-ebda70951c has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-ebda70951c

Comment 9 Fedora Update System 2020-08-27 19:05:06 UTC
FEDORA-2020-ebda70951c has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-ebda70951c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-ebda70951c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Igor Raits 2020-08-30 04:58:28 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 34.

Thanks for taking care of it!

Comment 11 Charalampos Stratakis 2020-09-07 17:59:02 UTC
Upstream has pushed https://github.com/BhallaLab/moose-core/commit/eafa8b2bfe010f85d7635a6a7fb9416346efef0c for the fixes.

Comment 12 Fedora Blocker Bugs Application 2020-09-10 16:51:10 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user churchyard using the blocker tracking app because:

 The package does not install without the proposed update.

Comment 13 Kamil Páral 2020-09-14 14:25:47 UTC
Accepted as a Beta freeze exception:
https://pagure.io/fedora-qa/blocker-review/issue/76

Comment 14 Fedora Update System 2020-09-14 23:43:49 UTC
FEDORA-2020-ebda70951c has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.