Bug 1808766 - RFE - EPEL8 branch of python-breathe
Summary: RFE - EPEL8 branch of python-breathe
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-breathe
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Davide Cavalca
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1828826 (view as bug list)
Depends On:
Blocks: EPELPackagersSIG 2059441
TreeView+ depends on / blocked
 
Reported: 2020-03-01 01:18 UTC by Gary Buhrmaster
Modified: 2022-07-17 02:06 UTC (History)
6 users (show)

Fixed In Version: python-breathe-4.11.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-17 02:06:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Gary Buhrmaster 2020-03-01 01:18:37 UTC
Description of problem:

Please provide python-breathe package for epel8.

Comment 1 Dan Čermák 2020-03-01 07:17:30 UTC
Sorry, but I currently don't have the time for that.

If you are willing to take care of the epel8 branch, I can make you a comaintainer. Otherwise, I'll have to close this as WONTFIX.

Comment 2 Gary Buhrmaster 2020-03-02 18:08:59 UTC
I am not much of a python packager, but have managed to do some spec file adjustments and a mock build of python-breath 4.11.1 (the latest that can reasonably run on EPEL8 due to other dependencies and was available for F29), so if building 4.11.1 for EPEL8 is acceptable, I am willing to be a co-maintainer.  My FAS userid is gtb.  Thanks.

Comment 3 Dan Čermák 2020-04-03 22:17:05 UTC
Sorry for taking so long to respond to this: could you please try to get a a newer version of breathe to build?

Comment 4 Gary Buhrmaster 2020-04-13 01:42:15 UTC
(In reply to dan.cermak from comment #3)

> Sorry for taking so long to respond...

No problem, we all have other things to work on, and as you can see I am not exactly being quickly responsive either, so my apologies too.

> could you please try to get a a newer version of breathe to build?

As I mentioned, I did try, but found it was not (reasonably within the effort level I am comfortable making) possible, due to the dependency tree, and at least (maybe others) python3-sphinx being at version 1.7.6 in the PowerTools repo that made any python-breathe version greater than 4.11.1 unbuildable (python-breathe 4.12 (the next release) states the requirement to be python3-sphinx 1.8, and trying to build python-breath 4.12 on EPEL8 with python-sphinx 1.7.6 gets object attribute errors when running python-sphinx).

I am not entirely sure of the entire lineage of python3-sphinx in the CentOS PowerTools repo, but as I understand it, those packages come from the (licensed) EL8 CodeReady Linux Builder sources, and I don't expect one is likely to see python3-sphinx upgraded any time soon(*), and as I understand it, EPEL cannot replace/upgrade any EL derived versions, so one is basically between a rock and hard place regarding versions(**).

As EL8 is (approximately) based on F29, and F29 had python-breath 4.11.1, that is likely where one is going to be stuck for a bit.

If the 4.11.1 version is not acceptable, let us just drop the entire request and mark this bug WONTFIX.

If you care, here is a copr build for python-breath with the modified spec file (which essentially defangs the python2 variant of the build).

https://copr.fedorainfracloud.org/coprs/gtb/python-breathe/

Thanks.



(*) I have no way to know if EL 8.2 will bring updates to the CRB packages, but that would a future consideration.

(**) I am not clear if modules provides a way, even under the non-replace requirements, for EPEL to overlay EL versions, but I *am* sure I don't fully understand modules, and EPEL's capability with them, to have any idea how one might proceed.

Comment 5 Dan Čermák 2020-04-13 19:16:33 UTC
(In reply to Gary Buhrmaster from comment #4)
> (In reply to dan.cermak from comment #3)
> 
> > Sorry for taking so long to respond...
> 
> No problem, we all have other things to work on, and as you can see I am not
> exactly being quickly responsive either, so my apologies too.
> 
> > could you please try to get a a newer version of breathe to build?
> 
> As I mentioned, I did try, but found it was not (reasonably within the
> effort level I am comfortable making) possible, due to the dependency tree,
> and at least (maybe others) python3-sphinx being at version 1.7.6 in the
> PowerTools repo that made any python-breathe version greater than 4.11.1
> unbuildable (python-breathe 4.12 (the next release) states the requirement
> to be python3-sphinx 1.8, and trying to build python-breath 4.12 on EPEL8
> with python-sphinx 1.7.6 gets object attribute errors when running
> python-sphinx).

I see, that is indeed a problem as breathe needs to fiddle quite a bit with sphinx and a higher version requirement is then a lot more work (especially if one is not familiar with sphinx' internals).

> 
> I am not entirely sure of the entire lineage of python3-sphinx in the CentOS
> PowerTools repo, but as I understand it, those packages come from the
> (licensed) EL8 CodeReady Linux Builder sources, and I don't expect one is
> likely to see python3-sphinx upgraded any time soon(*), and as I understand
> it, EPEL cannot replace/upgrade any EL derived versions, so one is basically
> between a rock and hard place regarding versions(**).
> 
> As EL8 is (approximately) based on F29, and F29 had python-breath 4.11.1,
> that is likely where one is going to be stuck for a bit.
> 
> If the 4.11.1 version is not acceptable, let us just drop the entire request
> and mark this bug WONTFIX.

Well, the question is more: are you willing to tackle the bug reports for a 2 year old breathe version ;-)

> 
> If you care, here is a copr build for python-breath with the modified spec
> file (which essentially defangs the python2 variant of the build).
> 
> https://copr.fedorainfracloud.org/coprs/gtb/python-breathe/
> 
> Thanks.
> 
> 
> 
> (*) I have no way to know if EL 8.2 will bring updates to the CRB packages,
> but that would a future consideration.
> 
> (**) I am not clear if modules provides a way, even under the non-replace
> requirements, for EPEL to overlay EL versions, but I *am* sure I don't fully
> understand modules, and EPEL's capability with them, to have any idea how
> one might proceed.

Well, modules would not really help here, as sphinx is a runtime dependency of breathe and not only a build time dependency. A build time dependency could be hidden in a module, but if a package from epel must not be overridden by a module, then modules will not be helpful here to cheat in a newer sphinx.

Long story short: if you are willing to maintain breathe 4.11 in epel and tackle any bugs that it receives, then I'll give you commit access to the repo and set you as the bugowner for the el8 branch. Deal?

Comment 6 Gary Buhrmaster 2020-04-16 03:19:52 UTC
As python-breathe cannot be updated in epel8, and I have insufficient expertice to backport any fixes in such a complex eco-system (breathe, sphinx, others?) I think that agreeing to take responsibility to actually address any bugs is wrong (all I could do is close WONTFIX as upstream is not going to backport anything either).

So, I see the only viable answer is close this bug WONTFIX.

Sorry to have wasted your time.

Comment 7 Dan Čermák 2020-04-28 13:00:15 UTC
*** Bug 1828826 has been marked as a duplicate of this bug. ***

Comment 8 Dan Čermák 2020-05-03 21:40:42 UTC
(In reply to Gary Buhrmaster from comment #6)
> As python-breathe cannot be updated in epel8, and I have insufficient
> expertice to backport any fixes in such a complex eco-system (breathe,
> sphinx, others?) I think that agreeing to take responsibility to actually
> address any bugs is wrong (all I could do is close WONTFIX as upstream is
> not going to backport anything either).

You could try to ask upstream what their stance on this is and/or on the epel-devel mailinglist if anyone else would be up to helping you out?

It's probably still going to be more work than in Fedora.

> 
> So, I see the only viable answer is close this bug WONTFIX.
> 
> Sorry to have wasted your time.

Please don't worry about it and maybe there is a solution as you are not the only one who wants breathe in EPEL 8.

Comment 9 markusN 2020-05-31 18:39:34 UTC
FYI: BZ#1741567 (GDAL 3.1.0) requires python-breathe for EPEL8.
It is also an issue for the PDAL package on EPEL8 (BZ#1838686).

Comment 10 Dan Čermák 2020-06-07 19:51:05 UTC
(In reply to markusN from comment #9)
> FYI: BZ#1741567 (GDAL 3.1.0) requires python-breathe for EPEL8.
> It is also an issue for the PDAL package on EPEL8 (BZ#1838686).

I will be more than happy to give a packager commit access to take care of a EPEL8 branch if they will also become the bugowner for EPEL8. Unfortunately I lack the time to maintain breathe in epel, so someone volunteering is required here.

Comment 11 Davide Cavalca 2022-05-10 22:23:27 UTC
The EPEL Packagers SIG would be happy to be a co-maintainer if you do not wish to build this package on epel8. Please add the epel-packagers-sig group through
https://src.fedoraproject.org/rpms/<package>/addgroup and grant it commit access, or collaborator access on epel* branches. Feel free to also set it as the bug owner.

Comment 12 Dan Čermák 2022-05-30 12:53:13 UTC
I have added the epel-packagers-sig as a collaborator to the epel* branches. Use your powers wisely ;-)

Comment 13 Davide Cavalca 2022-07-15 20:01:23 UTC
Thanks! Reopening as this isn't actually built yet. I've just requested the branch:

$ fedpkg request-branch epel8
https://pagure.io/releng/fedora-scm-requests/issue/45799

Comment 14 Fedora Update System 2022-07-15 22:15:54 UTC
FEDORA-EPEL-2022-a80a0e383e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-a80a0e383e

Comment 15 Fedora Update System 2022-07-16 01:51:29 UTC
FEDORA-EPEL-2022-a80a0e383e has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-a80a0e383e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2022-07-17 02:06:53 UTC
FEDORA-EPEL-2022-a80a0e383e has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.