Bug 1808821 - use of -fstrict-aliasing breaks lzo
Summary: use of -fstrict-aliasing breaks lzo
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-01 12:32 UTC by Julian Sikorski
Modified: 2020-10-05 08:28 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-01 15:01:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Julian Sikorski 2020-03-01 12:32:00 UTC
Description of problem:
lzo tests fail when lzo-2.10-1.fc32 is compiled with make check tests line re-enabled

Version-Release number of selected component (if applicable):
10.0.1-0.8.fc32

How reproducible:
always

Steps to Reproduce:
1. fedpkg clone lzo
2. cd lzo
3. remove the # in row 37 of lzo.spec
4. make mockbuild

Actual results:
failure at %check stage

Expected results:
build completes successfully

Additional info:
I have narrowed the problem down to -fstrict-aliasing and attached a workaround to https://bugzilla.redhat.com/show_bug.cgi?id=1807737

Comment 1 Jeff Law 2020-03-01 15:01:13 UTC
That's because the LZO code is broken, in particular lzo_config_check's violates the ISO C aliasing rules.  This affects not just LZO, but also packages that embed LZO such as syslinux.


Note You need to log in before you can comment on or make changes to this bug.