Bug 1808847 - apiVersion missing from node event involved object
Summary: apiVersion missing from node event involved object
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Ryan Phillips
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-01 15:17 UTC by Samuel Padgett
Modified: 2020-08-04 18:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.ci-2020-02-29-231846 Cluster ID: 3fd9b46d-6a5b-4a0a-9dba-4cadeb8bc703 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0
Last Closed: 2020-08-04 18:02:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24772 0 None closed Bug 1808847: UPSTREAM: 87537: Add apiVersion to involvedObject 2020-06-23 08:54:12 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:02:40 UTC

Description Samuel Padgett 2020-03-01 15:17:45 UTC
`involvedObjet.apiVersion` is missing from node events. This prevents console from showing node as the type (since it relies on `apiVersion` and `kind` to add a resource link).

Version: 4.5.0-0.ci-2020-02-29-231846

Here's an event with the problem:

- apiVersion: v1
  count: 1
  eventTime: null
  firstTimestamp: "2020-03-01T14:20:08Z"
  involvedObject:
    kind: Node
    name: ip-10-0-132-152.us-east-2.compute.internal
    uid: ip-10-0-132-152.us-east-2.compute.internal
  kind: Event
  lastTimestamp: "2020-03-01T14:20:08Z"
  message: Starting kubelet.
  metadata:
    creationTimestamp: "2020-03-01T14:20:08Z"
    name: ip-10-0-132-152.us-east-2.compute.internal.15f833f7e31baf6d
    namespace: default
    resourceVersion: "1974"
    selfLink: /api/v1/namespaces/default/events/ip-10-0-132-152.us-east-2.compute.internal.15f833f7e31baf6d
    uid: 803a3c58-c41a-4af7-b07a-09a239084219
  reason: Starting
  reportingComponent: ""
  reportingInstance: ""
  source:
    component: kubelet
    host: ip-10-0-132-152.us-east-2.compute.internal
  type: Normal

Comment 1 Ryan Phillips 2020-03-03 17:45:54 UTC
A node object is internal and lacks a version number, so I believe this is expected behavior.

Comment 3 Ryan Phillips 2020-03-03 22:18:03 UTC
Sam: After talking to David, would you like me to pick the patch, or would you like to code around it?

Patch is approved.

Comment 9 errata-xmlrpc 2020-08-04 18:02:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.