Bug 1808862 - NODEJS_VER=10 in registry.redhat.io/ubi8/nodejs-12
Summary: NODEJS_VER=10 in registry.redhat.io/ubi8/nodejs-12
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: nodejs-12-container
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Node.js maintainers
QA Contact: rhscl image testing
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-01 17:06 UTC by John L Magee
Modified: 2020-09-30 16:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-30 16:15:33 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description John L Magee 2020-03-01 17:06:13 UTC
Description of problem:
The environment variable NODEJS_VER is set to 10 

Version-Release number of selected component (if applicable):
registry.redhat.io/ubi8/nodejs-12:latest

How reproducible:
100%

Steps to Reproduce:
1. podman pull registry.redhat.io/ubi8/nodejs-12:latest
2. podman image inspect registry.redhat.io/ubi8/nodejs-12:latest | grep NODEJS_VER=
3.

Actual results:
"NODEJS_VER=10"

Expected results:
"NODEJS_VER=12"

Additional info:

Comment 1 Derrick Ornelas 2020-03-12 20:03:16 UTC
Moving to correct product/component

Comment 2 Vít Ondruch 2020-03-13 08:09:12 UTC
@Petře, could you please take a look?

Comment 3 Petr Kubat 2020-03-13 11:08:23 UTC
Thanks for the Vita! This is expected. The definition for the variable is actually coming from the s2i-base image [1] serving as a base layer for the nodejs image, which installs nodejs version 10 for layered images to use.
The nodejs-12 image specifically then removes the version 10 rpms and replaces them with version 12. [2]

[1] https://github.com/sclorg/s2i-base-container/blob/master/base/Dockerfile.rhel8#L10
[2] https://github.com/sclorg/s2i-nodejs-container/blob/master/12/Dockerfile.rhel8#L52

Comment 6 Vít Ondruch 2020-09-30 16:15:33 UTC
I think the original question was answered. Because there were no further comment from OP, think it is safe to close this ticket. Feel free to reopen if there are any additional concerns.


Note You need to log in before you can comment on or make changes to this bug.