Bug 180896 - xargs fails with large environment
xargs fails with large environment
Status: CLOSED DUPLICATE of bug 135129
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: findutils (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 07:19 EST by Göran Uddeborg
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 12:11:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Script triggering the bug (23.32 KB, text/plain)
2006-02-10 07:19 EST, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2006-02-10 07:19:35 EST
Description of problem:
If the environment is very large, xargs fails immediately on startup.

Version-Release number of selected component (if applicable):
findutils-4.1.7-9

How reproducible:
Every time

Steps to Reproduce:
1.Run the attached script

Actual results:
Output of "xargs: environment is too large for exec" and exit status 1.

Expected results:
No output and exit status 0.

Additional info:
This problem is fixed in later upstreams version.  The version in RHEL 4 (rpm -q
-f `which xargs`) is also not affected.  But RHEL 3 does fail.
Comment 1 Göran Uddeborg 2006-02-10 07:19:35 EST
Created attachment 124486 [details]
Script triggering the bug
Comment 2 Göran Uddeborg 2006-02-10 10:59:09 EST
Sorry about the silly reference to RHEL 4 findutils in comment 0.  It should say
findutils-4.1.20-7, of course.
Comment 3 Miloslav Trmač 2006-02-13 12:11:34 EST
Thanks for your report.  This is already tracked for RHEL 3, although probably
not easy to find.

*** This bug has been marked as a duplicate of 135129 ***
Comment 4 Göran Uddeborg 2006-02-13 12:39:36 EST
So it was the same!  I searched and found that one, but I was not sure it was
the same problem.  I wasn't sure if ARG_MAX was just for arguments, or actually
included the environment.  And the error message I saw wasn't mentioned there.

But if it indeed is about the same thing, than fine! :-)

Note You need to log in before you can comment on or make changes to this bug.