Bug 1809005 - No "nodeSelector=kubernetes.io/os: linux" label for image registry and image registry operator
Summary: No "nodeSelector=kubernetes.io/os: linux" label for image registry and image ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-02 09:13 UTC by Wenjing Zheng
Modified: 2020-08-04 18:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Operator is not setting nodeSelector label on image registry created resources. Consequence: This could have affected us in the future as we were not specifying in what nodes our resources can run, we could end up running the registry over unsupported platforms. Fix: Added the missing label to created resources. Result: It is possible to see the label on the created resources.
Clone Of:
Environment:
Last Closed: 2020-08-04 18:02:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 518 None closed Bug 1809005: Always set node selector kubernetes.io/os to linux 2020-07-24 20:02:20 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:02:55 UTC

Description Wenjing Zheng 2020-03-02 09:13:46 UTC
Description of problem:
There is no "nodeSelector=kubernetes.io/os: linux" label for image registry resources

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-01-215047

How reproducible:
Always

Steps to Reproduce:
1.Check image registry related resources, like cluster-image-registry-operator deployment and image-registry deployment
2.
3.

Actual results:
There is no label to indicates they cannot be scheduled to windows node

Expected results:
Should add a label

Additional info:

Comment 4 Wenjing Zheng 2020-05-13 09:19:54 UTC
I can see below nodeselector in image-registry deployment, but cannot see it in cluster-image-registry-operator deployment:
      nodeSelector:
        kubernetes.io/os: linux

Is it by design?

Comment 5 Ricardo Maraschini 2020-05-13 12:48:38 UTC
Yes, it is by design as per https://github.com/openshift/cluster-image-registry-operator/pull/518#discussion_r408918009

Comment 6 Wenjing Zheng 2020-05-14 08:46:38 UTC
Verified on 4.5.0-0.nightly-2020-05-13-221558:
     nodeSelector:
        kubernetes.io/os: linux

Comment 8 errata-xmlrpc 2020-08-04 18:02:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.