Bug 180908 - gcj-dbtool hangs when processing /usr/lib64/gcj/eclipse-cdt/cdtmicore.jar.db
gcj-dbtool hangs when processing /usr/lib64/gcj/eclipse-cdt/cdtmicore.jar.db
Status: CLOSED DUPLICATE of bug 179002
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 10:12 EST by Alan Krause
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 13:30:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Krause 2006-02-10 10:12:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
Whenever /usr/bin/rebuild-gcj-db is run (for example, after a java rpm is updated via yum), it eventually will hang when gcj-dbtool tries to merge /usr/lib64/gcj/eclipse-cdt/cdtmicore.jar.db into /usr/lib64/gcj-4.1.0/classmap.db.

I was able to narrow down with db file was causing the problem by tweaking the rebuild-gcj-db script to call gcj-dbtool with only one argument at a time (i.e. xargs -n1), and the eclipse cdtmicore db file causes it to hang every time.

I'm not sure if this is a gcj problem or an eclipse problem. However, a bad .db file probably shouldn't be able to hang the whole rebuild-db process either.

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp_78rh

How reproducible:
Always

Steps to Reproduce:
1. Make sure eclipse is installed (so that /usr/lib64/gcj/eclipse-cdt/cdtmicore.jar.db is present)
2. Execute /usr/bin/rebuild-gcj-db
  

Actual Results:  Hang-o-la. You have to kill the process with CTRL-C.

Expected Results:  It should rebuild the /usr/lib64/gcj-4.1.0/classmap.db file.

Additional info:
Comment 1 Thomas Fitzsimmons 2006-02-10 13:30:45 EST

*** This bug has been marked as a duplicate of 179002 ***

Note You need to log in before you can comment on or make changes to this bug.