Bug 1809096 - Progressbar during offline upgrade phase gets reset after entering "Verifying phase"
Summary: Progressbar during offline upgrade phase gets reset after entering "Verifying...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 31
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: amatej
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-02 12:30 UTC by František Zatloukal
Modified: 2020-04-18 00:07 UTC (History)
10 users (show)

Fixed In Version: dnf-plugins-extras-4.0.10-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-18 00:07:09 UTC
Type: Bug


Attachments (Terms of Use)

Description František Zatloukal 2020-03-02 12:30:11 UTC
Description of problem:
Progressbar shown in plymouth during offline upgrade gets reset after proceeding to verifying phase. I am not 100% sure this worked better previously, I've noticed this now.

Version-Release number of selected component (if applicable):
dnf-plugins-extras-4.0.8-2.fc31

How reproducible:
Always

Steps to Reproduce:
1. Initiate F31 > F32 upgrade (system-upgrade download, system-upgrade reboot)
2. Watch progressbar in plymouth screen

Actual results:
Progress gets higher just as expected and the starts again at 0% just to rise to 100% again.

Expected results:
Progressbar shouldn't reset to 0% once dnf starts to verify transaction.


Additional info:

Comment 1 František Zatloukal 2020-03-02 12:31:37 UTC
I am not sure if dnf-plugins-extras is right place to report and fix the issue, feel free to assign to a different component if needed.

Comment 2 František Zatloukal 2020-03-07 12:03:21 UTC
This doesn't happen when upgrading with GNOME Software.

Comment 3 amatej 2020-03-11 12:37:14 UTC
I have created a PR to fix resetting of the progressbar:
https://github.com/rpm-software-management/dnf-plugins-extras/pull/175

Writing automated tests for this would be very difficult, therefore I have verified the behavior only manually.

Comment 4 František Zatloukal 2020-03-23 11:34:29 UTC
Yes, the issue is solved after applying the PR. Thanks a lot! Can you make an updated dnf-plugins-extras and push it to F30 and F31?

Comment 5 Fedora Blocker Bugs Application 2020-03-23 11:35:51 UTC
Proposed as a Freeze Exception for 32-final by Fedora user frantisekz using the blocker tracking app because:

 It'd be nice to have this fixed before GA.

Comment 6 Geoffrey Marr 2020-03-23 19:42:21 UTC
Discussed during the 2020-03-23 blocker review meeting: [0]

The decision to classify this bug as a "RejectedFreezeException" was made as as this needs to be fixed in F30 and F31 for upgrades to F32, there is no justification for an F32 freeze exception, it would not achieve anything for the F32 release.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-23/f32-blocker-review.2020-03-23-16.00.txt

Comment 7 Fedora Update System 2020-04-02 12:50:29 UTC
FEDORA-2020-d51dbe83a9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d51dbe83a9

Comment 8 Fedora Update System 2020-04-03 20:49:55 UTC
FEDORA-2020-d51dbe83a9 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d51dbe83a9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d51dbe83a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-04-18 00:07:09 UTC
FEDORA-2020-d51dbe83a9 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.