Bug 180915 - missing epoch in Requires: throughout specfile
missing epoch in Requires: throughout specfile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 10:36 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-12 09:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-10 10:36:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060207 Fedora/1.5.0.1-2.1 Firefox/1.5.0.1

Description of problem:
eclipse-bugzilla requires eclipse-platform = 3.1.2, but that should be 1:3.1.2

Version-Release number of selected component (if applicable):
eclipse-bugzilla-0.1.1_fc-6

How reproducible:
Always

Steps to Reproduce:
1.Try to install eclipse-bugzilla other than with anaconda

Actual Results:  Error: Missing Dependency: eclipse-platform = 3.1.2 is needed by package eclipse-bugzilla

Expected Results:  No such error

Additional info:
Comment 1 Andrew Overholt 2006-02-10 11:06:36 EST
Sorry, this was because it should be >= 3.1.2 and not = 3.1.2.  I've fixed this
and it will appear in tomorrow's rawhide push.
Comment 2 Alexandre Oliva 2006-02-10 11:34:38 EST
Did you add the 1:?  If not, you'll be accepting any of the earlier eclipse
builds, since 3.1.2 <= 1:3.1.1.  What you want is >= 1:3.1.2.
Comment 3 Andrew Overholt 2006-02-10 11:38:55 EST
I can go through and add all the Epochs, but there are no other builds of 3.1.2
out there.  Well, I guess JPackage will do it eventually so I should probably
add them.  Man, what an idiot I am for adding that stupid epoch back when I did ...
Comment 4 Andrew Overholt 2006-02-10 11:41:08 EST
Oh, I'm an idiot.  I blindly assumed this was filed against eclipse (the SDK). 
I already went through and added %{epoch} there.  I will add it in the plugins
that we ship (bugzilla, changelog, pydev, and cdt).
Comment 5 Alexandre Oliva 2006-02-12 09:01:19 EST
Thanks, I see eclipse-bugzilla is fixed in today's rawhide.

Note You need to log in before you can comment on or make changes to this bug.