Bug 180916 - scalapack incompatible with blacs
scalapack incompatible with blacs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: scalapack (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 10:38 EST by Andrew Gormanly
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 09:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The changes to SLmake.inc (2.71 KB, patch)
2006-02-10 10:42 EST, Andrew Gormanly
no flags Details | Diff
Re-generated 64bit patch for correctness (1.11 KB, patch)
2006-02-10 10:43 EST, Andrew Gormanly
no flags Details | Diff
New SPEC file (3.26 KB, text/plain)
2006-02-10 10:44 EST, Andrew Gormanly
no flags Details

  None (edit)
Description Andrew Gormanly 2006-02-10 10:38:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060130 Red Hat/1.7.12-1.4.2

Description of problem:
scalapack-1.7-7.fc4 from Fedora Extras is incompatible with blacs-1.1-18.fc4 from Fedora Extras.  Specifically, scalapack has undefined symbols with trailing double underscores such as blacs_pinfo__ but blacs defines them as blacs_pinfo_ and so on.

Given that blacs is a dependancy for scalapack, this is silly.  I guess the maintainer of blacs released a new version and didn't check whether it broke scalapack.

(Also silly is the strange splitting of the blacs package contents into blacs and blacs-devel which occurred in the 1.1-18.fc4 release, with libmpiblacs.a and the symlink /usr/lib/libmpiblacs.so in the -devel package.)

Version-Release number of selected component (if applicable):
scalapack-1.7-7.fc4

How reproducible:
Always

Steps to Reproduce:
1. Compile code that requires scalapack
2. Link
3.
  

Actual Results:  Missing symbols all over the place

Expected Results:  Linking between scalapack and blacs should work, especially given that the former requires the latter.

Additional info:

Also, the SRPM does not rebuild on FC4: specifically,

(1) the CDEFS in SLmake.inc needs to be changed from -Df77IsF2C to -DAdd_ because gfortran only adds one underscore, unlike g77 which adds two underscores.

(2) there is a dependancy on libutil (references openpty), so that needed adding to EXTRALIBS in SLmake.inc

(3) the BuildRequires of blas-devel, blacs-devel and glibc-devel should be added to the spec file, and probably so should Requires of blas-devel and blacs-devel now that the .a's and the .so's have been put into those packages.

I've fixed these issues myself, and will upload the new spec and patches in a minute or two.
Comment 1 Andrew Gormanly 2006-02-10 10:42:00 EST
Created attachment 124504 [details]
The changes to SLmake.inc

Should be applied to SLmake.inc as distributed, i.e. is not a patch to the
patches in the SRPM
Comment 2 Andrew Gormanly 2006-02-10 10:43:28 EST
Created attachment 124505 [details]
Re-generated 64bit patch for correctness

As with 124504, this replaces the patch of the same name from 1.7-7.fc4
Comment 3 Andrew Gormanly 2006-02-10 10:44:40 EST
Created attachment 124507 [details]
New SPEC file

New BuildRequires and Requires, bump version number
Comment 4 Andrew Gormanly 2006-02-10 10:46:05 EST
New RPMs and SRPM are available at http://www.cmmp.ucl.ac.uk/~atg/scalapack/ but
untested yet due to a gfortran bug
Comment 5 Tom "spot" Callaway 2006-03-09 09:47:38 EST
scalapack is built for FC-3, FC-4, and FC-5 now. Thanks for the patches.

Note You need to log in before you can comment on or make changes to this bug.