Bug 1809194 - Metrics exposed over insecure channel
Summary: Metrics exposed over insecure channel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Devan Goodwin
QA Contact: wang lin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-02 14:57 UTC by Pawel Krupa
Modified: 2020-10-27 15:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:56:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 208 0 None closed Bug 1809194: expose metrics over https 2020-07-28 11:11:14 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:56:13 UTC

Description Pawel Krupa 2020-03-02 14:57:34 UTC
Description of problem:
Metrics endpoint is not using TLS to encrypt traffic.

Version-Release number of selected component (if applicable):
4.4 (possibly also earlier versions)

How reproducible:
Always

Steps to Reproduce:
1. Start a cluster
2. Go to prometheus UI
3. Check connection schema for this component

Actual results:
Metrics are exposed over HTTP connection

Expected results:
Metrics are exposed over HTTPS connection

Additional info:
API server operator ServiceMonitor definition can be used as a template on how to fix this issue: https://github.com/openshift/cluster-openshift-apiserver-operator/blob/master/manifests/0000_90_openshift-apiserver-operator_03_servicemonitor.yaml

Comment 1 Scott Dodson 2020-03-03 15:05:24 UTC
Tied to a 4.5 epic for monitoring team, moving to 4.5 target release.

Comment 2 Pawel Krupa 2020-04-06 11:41:36 UTC
After fixing please remove your component from an exclusion list in e2e tests at https://github.com/openshift/origin/blob/master/test/extended/prometheus/prometheus.go#L253-L268

Comment 3 Devan Goodwin 2020-05-15 17:43:37 UTC
We have not found time to schedule this yet, mirroring to Jira and will add to next sprint.

Comment 4 Greg Sheremeta 2020-06-18 18:21:57 UTC
PR in review

Comment 7 wang lin 2020-06-23 09:17:17 UTC
The bug fixed.
CCO metrics are exposed over HTTPS connection now, test payload: registry.svc.ci.openshift.org/ocp/release:4.6.0-0.nightly-2020-06-23-053310

Comment 9 errata-xmlrpc 2020-10-27 15:56:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.