Bug 180929 - missing -soname in shared lib
missing -soname in shared lib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tix (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 180934
  Show dependency treegraph
 
Reported: 2006-02-10 11:03 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 11:41:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-10 11:03:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060207 Fedora/1.5.0.1-2.1 Firefox/1.5.0.1

Description of problem:
The dynamic library installed by tix is missing an explicit SONAME specification.  This implies programs linked with -ltix will get libtix.so into their DT_NEEDED (this is the case of tkinter on x86_64, but oddly not on i386).  Since nothing provides libtix.so, rpm refuses to install tkinter on x86_64, even though the symlink is right there.

Version-Release number of selected component (if applicable):
tix-8.4.0-2

How reproducible:
Always

Steps to Reproduce:
1.gcc whatever.c -ltix
2.readelf -d a.out | grep tix

Actual Results:   0x0000000000000001 (NEEDED)             Shared library: [libtix.so]


Expected Results:   0x0000000000000001 (NEEDED)             Shared library: [libTix8.4.so]


Additional info:
Comment 1 David Cantrell 2006-02-10 11:41:25 EST
Corrected in rawhide.  The new package will be tix-8.4.0-3 and it should be in
tomorrow's tree build.

Note You need to log in before you can comment on or make changes to this bug.