Bug 18094 - File not found even though ls finds it...
File not found even though ls finds it...
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Depends On:
  Show dependency treegraph
Reported: 2000-10-02 10:30 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-02 10:55:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-02 10:30:45 EDT
After installing RH7 (Deluxe), I tried installing Matlab 5, which worked
fine under all previous versions of Linux.  However, after installing, I
get the message 

/usr/local/matlab5/bin/lnx86/matlab: No such file or directory

which is very strange since that file exists.  Even cd'ing into that
directory and doing ./matlab still gives me the "No such file..." error
even though I chmod'd +777 it (and tried the command as root).  A similar
thing happened on the installation of Matlab since it could not find a
file xsetup (even though it was on the CDROM), but I got around that using
a text install.  

Now, the point is that I strongly believe this is *not* a Matlab problem,
but a problem of Linux since even if the file was completely screwed up,
doing ./matlab would still give back some other error message than "No
such file..."   Of course, I also tried adding . to my PATH too.  That did
not help.

(By the way, I selected bash as the component, since I could not think of
what could cause this.)
Comment 1 Bernhard Rosenkraenzer 2000-10-02 10:43:14 EDT
By any chance, is /usr/local/matlab5/bin/lnx86/matlab a script?
If you try to execute a script that requires a shell that doesn't exist (i.e. a
script that starts with "#!/bin/my-nonstandard-shell"), it should and will
generate "File not found".

Please add the output of "head -n5 /usr/local/matlab5/bin/lnx86/matlab"
Comment 2 Need Real Name 2000-10-02 10:55:38 EDT
No, this is definitely *not* a script.  head ... gives

            4 (tse44?4?  cbTT?T?rrc``??dy
P]P]xxec/lib/ld-linux.so.1  a


(and some more stuff like that).  It is an executable file.  

However, as I said before it should not matter what kind of file this is. As
long as it's executable, *something* should happen, but definitely not a "No
such file..." error.
Comment 3 Bernhard Rosenkraenzer 2000-10-02 10:58:35 EDT
Wrong guess, same reason: The header shows it wants /lib/ld-linux.so.1 - this is
libc5 stuff.
We no longer support libc5.

If you need to run it, install the libc5 compat packages (libc and ld.so) from
Comment 4 Need Real Name 2000-10-03 20:46:56 EDT
May be it should give to the user some indication of the real cause of the error
... and certainly not say "File not found ....!!!"

Note You need to log in before you can comment on or make changes to this bug.