Bug 180952 - Conflicts between libnet-devel and libnet10
Conflicts between libnet-devel and libnet10
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libnet (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 180897
  Show dependency treegraph
 
Reported: 2006-02-10 14:15 EST by Jason Tibbitts
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-11 11:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2006-02-10 14:15:18 EST
I'm not sure how to handle this.  I'm trying to build the heartbeat package in
mock, but it BuildRequires: both libnet10 and libnet-devel, which can't both be
installed:

Transaction Check Error:   file /usr/bin/libnet-config conflicts between
attempted installs of libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
  file /usr/include/libnet.h conflicts between attempted installs of
libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
  file /usr/include/libnet/libnet-asn1.h conflicts between attempted installs of
libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
  file /usr/include/libnet/libnet-functions.h conflicts between attempted
installs of libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
  file /usr/include/libnet/libnet-headers.h conflicts between attempted installs
of libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
  file /usr/include/libnet/libnet-macros.h conflicts between attempted installs
of libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
  file /usr/include/libnet/libnet-structures.h conflicts between attempted
installs of libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
  file /usr/lib/libnet.a conflicts between attempted installs of
libnet-devel-1.1.2.1-6.fc5 and libnet10-1.0.2a-9.fc5
Comment 1 Michael Schwendt 2006-02-11 07:58:09 EST
First of all, this is a packaging bug in "heartbeat".
It must not BuildRequire both libnet10 and libnet-devel.

Secondly, we removed/obsoleted libnet10 some time last year, because
it is not needed anymore and is packaged incorrectly. Despite the
package name, it cannot coexist with libnet/libnet-devel, because it
stores files in the same locations. This was due to an exception in the
packaging policies at fedora.us, where the clean buildroots permitted
mutually exclusive build requirements. At Fedora Extras, conflicts are
not allowed. It is not worth relocating the files either because the
package is not needed. For ordinary upgrades, libnet and libnet-devel
upgrade libnet10 (see the versioned Provides in the package). If,
however, you tell yum you want both, this either leads to problems in
the transaction check or during installation (files from one package
overwrite files from the other package). libnet10 should just go.
Comment 2 Patrice Dumas 2006-02-11 11:04:54 EST
heartbeat can use the new api.

I still think that we can keep that package with the conflict with newer libnet
such that users can use libnet10 if they really need to.

Note You need to log in before you can comment on or make changes to this bug.