Bug 1809546 - Topology layout is stacking nodes vertically
Summary: Topology layout is stacking nodes vertically
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1809109
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-03 11:47 UTC by Jeff Phillips
Modified: 2020-05-04 11:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1809109
Environment:
Version: 4.5.0-0.ci-2020-03-01-212531 Cluster ID: b2eafd5a-d2eb-4d3e-93e5-eebe0c16a95c Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36
Last Closed: 2020-05-04 11:44:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4602 0 None closed [release-4.4] Bug 1809546: Fix for topology layout stacking resources 2020-04-28 20:24:28 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:44:42 UTC

Description Jeff Phillips 2020-03-03 11:47:58 UTC
+++ This bug was initially created as a clone of Bug #1809109 +++

Description of problem:

The topology layout is making in hard to see nodes and understand node connections.


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Open a project with multiple resources
2. Navigate to Developer perspective -> Topology

Actual results:

The topology is laying out nodes vertically making it hard to see all the nodes:

Expected results:

Nodes should be laid out both vertically and horizontally thus showing more nodes.


Additional info:

Comment 3 Gajanan More 2020-03-05 10:36:05 UTC
I have validated this bug on:
Build: 4.4.0-0.nightly-2020-03-05-014624
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 5 errata-xmlrpc 2020-05-04 11:44:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.