Bug 1809609 - Edit flow should only be available on applications created via the Add flow
Summary: Edit flow should only be available on applications created via the Add flow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
: 1809608 (view as bug list)
Depends On: 1807561
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-03 13:48 UTC by Jaivardhan Kumar
Modified: 2020-05-13 22:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1807561
Environment:
Last Closed: 2020-05-13 22:00:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Application created by CLI doesn't have edit option (128.05 KB, image/png)
2020-03-05 10:02 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4608 0 None closed [release-4.4] Bug 1809609: show edit option for only resources created via add flow. 2020-04-22 18:49:30 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:21 UTC

Description Jaivardhan Kumar 2020-03-03 13:48:18 UTC
+++ This bug was initially created as a clone of Bug #1807561 +++

Description of problem:
In some cases edit resource is not working if resources is not created via add flow.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a deployment resource using CLI.
2. navigate to topology view.
3. right click and select option Edit <--deployment resource name-->
4. It will redirect to edit form but all the field are not auto filled.

Actual results:
Filled are not auto filled and it failed.

Expected results:
The option to `Edit ${resource name}` on a workload should only be available if the workload was created via the `Add` flow.

Additional info:

Comment 1 Jaivardhan Kumar 2020-03-03 13:54:58 UTC
*** Bug 1809608 has been marked as a duplicate of this bug. ***

Comment 4 Gajanan More 2020-03-05 10:02:08 UTC
I have validated this bug on:
Build: 4.4.0-0.nightly-2020-03-05-014624
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 5 Gajanan More 2020-03-05 10:02:58 UTC
Created attachment 1667694 [details]
Application created by CLI doesn't have edit option

Comment 7 errata-xmlrpc 2020-05-13 22:00:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.