Bug 1809798 - In-Context Doesn't Deploy Outside of Applications
Summary: In-Context Doesn't Deploy Outside of Applications
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On: 1809797
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-03 21:46 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1809797
Environment:
Last Closed: 2020-05-04 11:44:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4643 0 None open Bug 1809798: In-Context No Application Fix 2020-03-04 22:02:40 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:44:47 UTC

Description Andrew Ballantyne 2020-03-03 21:46:36 UTC
+++ This bug was initially created as a clone of Bug #1809797 +++

Description of problem:
When dragging the context handle outside of all applications and going through the in-context flow, it just ends up in a pre-existing application group.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Pre-req: Have an existing application inside an application group added into a project

1. From the pre-existing application, drag the handle off into open space (not on another application or application group)
2. Select any of the pop-up options (ie, From Git)
3. Fill out the form

Actual results:
The application appears in a pre-existing application (might be the one from before if you have multiple)

Expected results:
The new application should appear on it's own (not in an application group)

Additional info:

Comment 3 Karthik Jeeyar 2020-03-06 07:26:35 UTC
Verified on Openshift 4.5:
Build number : 4.5.0-0.ci-2020-03-05-232742
Cluster Url : https://console-openshift-console.apps.gamore45installer0603.devcluster.openshift.com/topology/ns/karthik/graph
Browsers : chrome (Version 79.0.3945.88), firefox (66.0.2)
Verified as : kubeadmin and test ( Logged a bug for view only user)

Comment 4 Karthik Jeeyar 2020-03-06 07:28:45 UTC
Verifeied Openshift 4.4:
Build number : 4.4.0-0.ci-2020-03-05-141938
Cluster Url : https://console-openshift-console.apps.sp85.devcluster.openshift.com/topology/ns/karthik/graph
Browsers : chrome (Version 79.0.3945.88), firefox (66.0.2)
Verified as : kubeadmin and test ( Logged a bug for view only user)

Comment 6 errata-xmlrpc 2020-05-04 11:44:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.