Bug 18098 - intall bug: anaconda fails after HD format
intall bug: anaconda fails after HD format
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 11:04 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 11:04:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-02 11:04:15 EDT
The bug occurs with a 3dfx Voodoo3 2000 and an Nvidia GeForce2 MX, so it
isn't the video card.  One difference with my system is I have a DVD-ROM
drive that does not want to boot CD-ROMs, so I had to make a boot floppy.

I'll also paste a sysinfo thing I did after I installed Mandrake.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/dos

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Sysinfo thing:

Technotes: Ray Clouse

undertow.rdc.lan


Thu Sep 28 08:10:52 PDT 2000


      Hardware Manufacturer:  Abit
      Machine Model........:  BM6
      System Serial Number :  dunno
      System Specifics.....:   GenuineIntel  6
       Celeron (Mendocino),  551 MHz
                              196192 kB RAM
                              136512 kB swap space
      Operating System.....:  Linux version 2.2.15-4mdk
(chmou@kenobi.mandrakesoft.com) (gcc version 2.95.3 19991030 (prerelease))
#1 Wed May 10 15:31:30 CEST 2000



I/O Ports



      0000-001f : dma1
      0020-003f : pic1
      0040-005f : timer
      0060-006f : keyboard
      0070-007f : rtc
      0080-008f : dma page reg
      00a0-00bf : pic2
      00c0-00df : dma2
      00f0-00ff : fpu
      0170-0177 : ide1
      01f0-01f7 : ide0
      0220-022f : soundblaster
      02f8-02ff : serial(auto)
      0330-0333 : MPU-401 UART
      0376-0376 : ide1
      0388-038b : Yamaha OPL3
      03c0-03df : vga+
      03f6-03f6 : ide0
      03f8-03ff : serial(auto)
      e000-e013 : usb-uhci
      e400-e41f : eth0
      f000-f007 : ide0
      f008-f00f : ide1



Interrupts



                 CPU0       
        0:    4415535          XT-PIC  timer
        1:       1991          XT-PIC  keyboard
        2:          0          XT-PIC  cascade
        5:      65124          XT-PIC  soundblaster
        8:          1          XT-PIC  rtc
       10:          0          XT-PIC  usb-uhci
       11:     131476          XT-PIC  eth0
       12:     248625          XT-PIC  PS/2 Mouse
       13:          1          XT-PIC  fpu
       14:     266735          XT-PIC  ide0
       15:          3          XT-PIC  ide1
      NMI:          0



PCI Devices



      PCI devices found:
        Bus  0, device   0, function  0:
          Host bridge: Intel 440BX - 82443BX Host (rev 3).
            Medium devsel.  Master Capable.  Latency=64.  
            Prefetchable 32 bit memory at 0xe0000000 [0xe0000008].
        Bus  0, device   1, function  0:
          PCI bridge: Intel 440BX - 82443BX AGP (rev 3).
            Medium devsel.  Master Capable.  Latency=64.  Min Gnt=136.
        Bus  0, device   7, function  0:
          ISA bridge: Intel 82371AB PIIX4 ISA (rev 2).
            Medium devsel.  Fast back-to-back capable.  Master Capable.  No
bursts.  
        Bus  0, device   7, function  1:
          IDE interface: Intel 82371AB PIIX4 IDE (rev 1).
            Medium devsel.  Fast back-to-back capable.  Master Capable. 
Latency=64.  
            I/O at 0xf000 [0xf001].
        Bus  0, device   7, function  2:
          USB Controller: Intel 82371AB PIIX4 USB (rev 1).
            Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master
Capable.  No bursts.  
            I/O at 0xe000 [0xe001].
        Bus  0, device   7, function  3:
          Bridge: Intel 82371AB PIIX4 ACPI (rev 2).
            Medium devsel.  Fast back-to-back capable.  
        Bus  0, device  11, function  0:
          Ethernet controller: Realtek 8029 (rev 0).
            Medium devsel.  IRQ 11.  
            I/O at 0xe400 [0xe401].
        Bus  1, device   0, function  0:
          VGA compatible controller: 3Dfx Unknown device (rev 1).
            Vendor id=121a. Device id=5.
            Fast devsel.  Fast back-to-back capable.  IRQ 9.  
            Non-prefetchable 32 bit memory at 0xe4000000 [0xe4000000].
            Prefetchable 32 bit memory at 0xe8000000 [0xe8000008].
            I/O at 0xd000 [0xd001].



SCSI Devices



      Attached devices: none



Disk Configuration



      Filesystem           1k-blocks      Used Available Use% Mounted on
      /dev/hdb1              6071904   1695560   4067900  29% /
      /dev/hdb2              2023952   1422052    499084  74% /beta
      /dev/hdb5              3734272   2895958    645134  82% /home
      /dev/hda1              4088532   2827936   1260596  69% /mnt/windows
      /dev/hdb6              1011928    553124    407400  58% /usr/local
      /dev/hda5              4013345   2659169   1146538  70% /usr1
      aenima:/home/clouse   29261404  10661912  17113080  38%
/aenima/clouse
      aenima:/home/ftp      29261404  10661912  17113080  38% /aenima/ftp
      aenima:/home/httpd    29261404  10661912  17113080  38% /aenima/httpd



ifconfig -a



      eth0      Link encap:Ethernet  HWaddr 00:50:BA:A2:AC:CB  
                inet addr:192.168.1.100  Bcast:192.168.1.255 
Mask:255.255.255.0
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:97805 errors:0 dropped:51 overruns:0 frame:38
                TX packets:55668 errors:0 dropped:0 overruns:0 carrier:0
                collisions:74 txqueuelen:100 
                Interrupt:11 Base address:0xe400 

      lo        Link encap:Local Loopback  
                inet addr:127.0.0.1  Mask:255.0.0.0
                UP LOOPBACK RUNNING  MTU:3924  Metric:1
                RX packets:234 errors:0 dropped:0 overruns:0 frame:0
                TX packets:234 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:0 




netstat -rn



      Kernel IP routing table
      Destination     Gateway         Genmask         Flags   MSS Window 
irtt Iface
      192.168.1.100   0.0.0.0         255.255.255.255 UH        0
0          0 eth0
      192.168.1.0     0.0.0.0         255.255.255.0   U         0
0          0 eth0
      127.0.0.0       0.0.0.0         255.0.0.0       U         0
0          0 lo
      0.0.0.0         192.168.1.1     0.0.0.0         UG        0
0          0 eth0



/etc/lilo.conf



      boot=/dev/hdb1
      map=/boot/map
      install=/boot/boot.b
      vga=0x0f02
      default=linux
      keytable=/boot/us.klt
      lba32
      message=/boot/message
      image=/boot/vmlinuz
              label=linux
              root=/dev/hdb1
              read-only
      image=/boot/vmlinuz
              label=failsafe
              root=/dev/hdb1
              append=" failsafe"
              read-only
      other=/dev/hda1
              label=windows
              table=/dev/hda
              map-drive=0x80
                 to=0x81
              map-drive=0x81
                 to=0x80
      other=/dev/fd0
              label=floppy
              unsafe



Inetd Services



      ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  in.ftpd -l -a
      telnet  stream  tcp     nowait  root    /usr/sbin/tcpd  in.telnetd
      pop-3   stream  tcp     nowait  root    /usr/sbin/tcpd  ipop3d



rc3.d Services



      /etc/rc.d/rc3.d/S05kudzu
      /etc/rc.d/rc3.d/S09sound
      /etc/rc.d/rc3.d/S10network
      /etc/rc.d/rc3.d/S11portmap
      /etc/rc.d/rc3.d/S16apmd
      /etc/rc.d/rc3.d/S20random
      /etc/rc.d/rc3.d/S25netfs
      /etc/rc.d/rc3.d/S30syslog
      /etc/rc.d/rc3.d/S35identd
      /etc/rc.d/rc3.d/S40atd
      /etc/rc.d/rc3.d/S40crond
      /etc/rc.d/rc3.d/S47irda
      /etc/rc.d/rc3.d/S50inet
      /etc/rc.d/rc3.d/S60lpd
      /etc/rc.d/rc3.d/S60nfslock
      /etc/rc.d/rc3.d/S72autofs
      /etc/rc.d/rc3.d/S75keytable
      /etc/rc.d/rc3.d/S80postfix
      /etc/rc.d/rc3.d/S84usb
      /etc/rc.d/rc3.d/S85gpm
      /etc/rc.d/rc3.d/S85httpd
      /etc/rc.d/rc3.d/S85numlock
      /etc/rc.d/rc3.d/S89drakfont
      /etc/rc.d/rc3.d/S90webmin
      /etc/rc.d/rc3.d/S90xfs
      /etc/rc.d/rc3.d/S95kheader
      /etc/rc.d/rc3.d/S99linuxconf
      /etc/rc.d/rc3.d/S99local



Possible Samba Shares



      [global]
         workgroup = MYGROUP
         server string = Samba Server
         printcap name = /etc/printcap
         load printers = yes
log file = /var/log/samba/log.%m
         max log size = 50
         security = user
         socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
         dns proxy = no 
      [homes]
         comment = Home Directories
         browseable = no
         writable = yes
      [printers]
         comment = All Printers
         path = /var/spool/samba
         browseable = no
         guest ok = no
         writable = no
         printable = yes



Print queues



      lp:
              queuing is enabled
              printing is enabled
              no entries
              no daemon present
Comment 1 Alan Cox 2000-10-02 11:54:52 EDT

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.