Bug 180981 - tcpdump -i ib0 not working with OpenIB IPoIb
tcpdump -i ib0 not working with OpenIB IPoIb
Status: CLOSED DUPLICATE of bug 180980
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcpdump (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2006-02-10 17:28 EST by Scott Weitzenkamp
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-10 17:30:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Scott Weitzenkamp 2006-02-10 17:28:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I am using 2.6.9-27 x86_64 and ia64 kernels, testing OpenIB.  IPoIB is working in general, but tcpdump does not work with IPoIB.

# tcpdump -i ib0
tcpdump: ioctl: Value too large for defined data type

strace says:

ioctl(3, SIOCGIFINDEX, {ifr_name="lo", ifr_index=1}) = 0
ioctl(3, SIOCGIFHWADDR, {ifr_name="ib0", ???}) = -1 EOVERFLOW (Value too large f
or defined data type)
close(3)                                = 0
write(2, "tcpdump: ", 9tcpdump: )                = 9
write(2, "ioctl: Value too large for defin"..., 44ioctl: Value too large for def
ined data type) = 44

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. modprobe ib_ipoib
2. tcpdump -i ib0

Actual Results:  command failed

Expected Results:  packet dump

Additional info:

Comment 1 Scott Weitzenkamp 2006-02-10 17:30:20 EST

*** This bug has been marked as a duplicate of 180980 ***

Note You need to log in before you can comment on or make changes to this bug.