Bug 1809812 - Catalog background overflows slightly on mobile
Summary: Catalog background overflows slightly on mobile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-03 22:25 UTC by ralpert
Modified: 2020-07-13 17:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
We were not hiding overflow on one of the containers in Operator Hub, causing the background to overflow. I added overflow: hidden to the offending container and the gray background no longer overflows.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:17:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of issue (118.51 KB, image/png)
2020-03-03 22:25 UTC, ralpert
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4751 None closed Bug 1809812: Fix catalog overflow on mobile 2020-06-23 08:58:21 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:18:17 UTC

Description ralpert 2020-03-03 22:25:22 UTC
Created attachment 1667324 [details]
Screenshot of issue

Description of problem:

The gray background in Operator Hub/Dev Catalog overflows the "frame" at mobile in all browsers.


Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Go to Operator Hub
2. Resize window to mobile size

Actual results:
Gray background overflows the frame.

Expected results:
Gray background stays within the frame.

Comment 3 Yanping Zhang 2020-03-20 02:30:43 UTC
Checked on OCP 4.5 cluster with payload 4.5.0-0.nightly-2020-03-19-112259. Goto operator hub page or catalog page, resize window to mobile size. Now gray background stays within the frame.
The bug is fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2020-07-13 17:17:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.