This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 180984 - gnome-screensaver should not be default if xscreensaver is installed.
gnome-screensaver should not be default if xscreensaver is installed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 19:29 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 11:57:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2006-02-10 19:29:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060208 Fedora/1.7.12-4.1

Description of problem:
Due to less than desirable features compared to xscreensaver, gnome-screensaver should not be installed on upgraded systems which have xscreensaver installed or not be the default screensaver if installed.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a new system or select "gnome desktop group" through pirut or yum.
2. wait for screensaver to display
3. Notice very few screensavers
  

Actual Results:  Did not like what I experienced with the program. I Ran 'rpm -e gnome-screensaver' in order for xscreensaver to display.

Expected Results:  I expected people passing by to comment positively about the decent screensavers.
I expected to be impressed by the decent screensavers xscreensaver provides.
gnome-screensaver to not be installed or staying out of the way unless specifically chosen.

Additional info:

I desire to remove the program because of its lack of configurability and lack of features. Though it is part of the gnome desktop, it should need to be selected. There are programs that are part of gnome but are not installed by default. (gftp) Not installing gnome-screensaver by default would be better.
Also people not familiar with Linux are impressed by the screensavers provided by xscreensaver.
Comment 1 Ray Strode [halfline] 2006-02-12 18:16:10 EST
Hi,

If you have the latest rawhide gnome-screensaver package and xscreensaver-extras
and/or xscreensaver-gl-extras installed, you should see xscreensaver's
screensaver s in gnome-screensaver.

Is it not working for you?
Comment 2 Nalin Dahyabhai 2006-02-13 08:49:18 EST
I have xscreensaver-extras and xscreensaver-gl-extras 4.24-1 installed, and the
only items visible in the screensaver preferences dialog when I run it are the
ones provided with gnome-screensaver.
Comment 3 Ray Strode [halfline] 2006-02-13 11:57:28 EST
Hi this should be fixed in tomorrow's rawhide.  If it's not, please reopen.
Comment 4 Jim Cornette 2006-02-16 09:08:35 EST
I removed the package as quickly as pirut and initial setup installed the
program. I will install and see if the configurability and the selectability for
more xscreensaver type screensavers is available tonight.
Comment 5 Jim Cornette 2006-02-16 18:29:53 EST
The other screensavers now show in the menu. The main distraction was not using
the screensavers. The configuration portion is tollerable and should not cause a
stir when FC5 is released.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.