Bug 1810007 - Unable to connect with ERR_DNS_FAIL and HTTP503 status
Summary: Unable to connect with ERR_DNS_FAIL and HTTP503 status
Keywords:
Status: CLOSED DUPLICATE of bug 1810005
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: squid
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Luboš Uhliarik
QA Contact: RHEL Stacks Subsystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 11:48 UTC by kazuhiro kawana
Modified: 2020-03-04 11:52 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-04 11:51:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description kazuhiro kawana 2020-03-04 11:48:27 UTC
Created attachment 1667463 [details]
strace

### Description of problem:
Unable to connect with ERR_DNS_FAIL and HTTP503 status on squid.

The customer using IPV6.
...snip...
tcp6       0      0 :::8080                 :::*                    LISTEN      0          585824275  27419/(squid-1)      off (0.00/0/0)
tcp6       0      0 :::1522                 :::*                    LISTEN      0          19036      1185/xinetd          off (0.00/0/0)
tcp6       0      0 :::21                   :::*                    LISTEN      0          18822      1197/vsftpd          off (0.00/0/0)
tcp6       0      0 :::22                   :::*                    LISTEN      0          19089      1174/sshd            off (0.00/0/0)


...access.log (Excerpt)...
$ cat /sosreport-pr-273961-001-pr-273961-001-2020-03-02-vrkzuxb/var/log/squid/access.log | grep   accounts.google.com:443
172.17.4.11 55372 - - [02/Mar/2020:15:33:47 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 4664 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.2.11 57306 - - [02/Mar/2020:15:34:57 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 4776 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.2.21 65337 - - [02/Mar/2020:15:38:18 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 478941 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.5.102 61723 - - [02/Mar/2020:15:44:49 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 1950 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.3.10 58929 - - [02/Mar/2020:15:47:28 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 477800 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.2.21 65424 - - [02/Mar/2020:15:47:55 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 950204 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.2.21 49209 - - [02/Mar/2020:15:52:16 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" accounts.google.com "-" 200 518743 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.5.40 57610 - - [02/Mar/2020:15:53:16 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 4872 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.4.91 61309 - - [02/Mar/2020:15:58:37 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 4616 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.4.91 61618 - - [02/Mar/2020:15:59:01 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 1545 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.4.91 61845 - - [02/Mar/2020:16:00:10 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 1529 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.4.91 61918 - - [02/Mar/2020:16:00:26 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 1545 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.2.21 49249 - - [02/Mar/2020:16:00:39 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" accounts.google.com "-" 200 1190144 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.2.21 49310 - - [02/Mar/2020:16:01:39 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" accounts.google.com "-" 200 5874 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.4.83 64526 - - [02/Mar/2020:16:02:53 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 4680 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.4.69 54095 - - [02/Mar/2020:16:05:30 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 4520 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.5.102 61947 - - [02/Mar/2020:16:06:23 +0900] "CONNECT accounts.google.com:443 HTTP/1.0" accounts.google.com "-" 200 1593 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" "-" - TCP_TUNNEL:HIER_DIRECT/216.58.197.13
172.17.2.21 49437 - - [02/Mar/2020:16:10:03 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" - "-" 503 0 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TAG_NONE:HIER_NONE/-
172.17.2.21 49452 - - [02/Mar/2020:16:10:03 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" - "-" 503 0 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TAG_NONE:HIER_NONE/-
172.17.2.21 49461 - - [02/Mar/2020:16:10:06 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" - "-" 503 0 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TAG_NONE:HIER_NONE/-
172.17.2.21 49465 - - [02/Mar/2020:16:10:14 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" - "-" 503 0 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TAG_NONE:HIER_NONE/-
172.17.2.21 49500 - - [02/Mar/2020:16:10:37 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" - "-" 503 0 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TAG_NONE:HIER_NONE/-
172.17.2.21 49508 - - [02/Mar/2020:16:11:38 +0900] "CONNECT accounts.google.com:443 HTTP/1.1" - "-" 503 0 "-" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36" "-" - TAG_NONE:HIER_NONE/-


...strace-202003021715.txt(Excerpt)...
27419 17:15:25.483913 getsockname(41<TCPv6:[::ffff:192.168.229.80:8080->::ffff:172.17.4.22:52274]>, {sa_family=AF_INET6, sin6_port=htons(8080), inet_pton(AF_INET6, "::ffff:192.168.229.80", &sin6_addr), sin6_flowinfo=0, sin6_scope_id=0}, [28]) = 0 <0.000012>
27419 17:15:25.483969 fcntl(41<TCPv6:[::ffff:192.168.229.80:8080->::ffff:172.17.4.22:52274]>, F_GETFD) = 0 <0.000012>
27419 17:15:25.484012 fcntl(41<TCPv6:[::ffff:192.168.229.80:8080->::ffff:172.17.4.22:52274]>, F_SETFD, FD_CLOEXEC) = 0 <0.000011>
27419 17:15:25.484054 fcntl(41<TCPv6:[::ffff:192.168.229.80:8080->::ffff:172.17.4.22:52274]>, F_GETFL) = 0x2 (flags O_RDWR) <0.000011>
27419 17:15:25.484095 fcntl(41<TCPv6:[::ffff:192.168.229.80:8080->::ffff:172.17.4.22:52274]>, F_SETFL, O_RDWR|O_NONBLOCK) = 0 <0.000012>
27419 17:15:25.484138 socket(AF_INET, SOCK_STREAM, IPPROTO_IP) = 42<TCP:[589293739]> <0.000034>
27419 17:15:25.484266 ioctl(42<TCP:[589293739]>, SIOCGARP, 0x7ffd5fa576c0) = -1 ENODEV (No such device) <0.000015>
27419 17:15:25.484367 ioctl(42<TCP:[589293739]>, SIOCGIFCONF, {64 * sizeof(struct ifreq) => 2 * sizeof(struct ifreq), [{ifr_name="lo", ifr_addr={AF_INET, inet_addr("127.0.0.1")}}, {ifr_name="eth0", ifr_addr={AF_INET, inet_addr("192.168.229.80")}}]}) = 0 <0.000016>
27419 17:15:25.484476 ioctl(42<TCP:[589293739]>, SIOCGARP, 0x7ffd5fa576c0) = -1 ENXIO (No such device or address) <0.000016>
27419 17:15:25.484575 close(42<TCP:[589293739]>) = 0 <0.000018>
27419 17:15:25.484679 write(35<TCPv6:[::ffff:192.168.229.80:8080->::ffff:172.17.4.64:53544]>, "HTTP/1.1 503 Service Unavailable\r\nServer: squid\r\nMime-Version: 1.0\r\nDate: Mon, 02 Mar 2020 08:15:25 GMT\r\nContent-Type: text/html;charset=utf-8\r\nContent-Length: 3688\r\nX-Squid-Error: ERR_DNS_FAIL 0\r\nVary: Accept-Language\r\nContent-Language: en\r\n\r\n<!DOCTYPE html PUBLIC \"-//W3C//DTD HTML 4.01//EN\" \"http://www.w3.org/TR/html4/strict.dtd\">\n<html><head>\n<meta type=\"copyright\" content=\"Copyright (C) 1996-2016 The Squid Software Foundation and contributors\">\n<meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\">\n<title>ERROR: The requested URL could not be retrieved</title>\n<style type=\"text/css\"><!-- \n /*\n * Copyright (C) 1996-2016 The Squid Software Foundation and contributors\n *\n * Squid software is distributed under GPLv2+ license and includes\n * contributions from numerous individuals and organizations.\n * Please see the COPYING and CONTRIBUTORS files for details.\n */\n\n/*\n Stylesheet for Squid Error pages\n Adapted from design by Free CSS Templates\n http://www.freecsstemplates.org\n Released for free under a Creative Commons Attribution 2.5 License\n*/\n\n/* Page basics */\n* {\n\tfont-family: verdana, sans-serif;\n}\n\nhtml body {\n\tmargin: 0;\n\tpadding: 0;\n\tbackground: #efefef;\n\tfont-size: 12px;\n\tcolor: #1e1e1e;\n}\n\n/* Page displayed title area */\n#titles {\n\tmargin-left: 15px;\n\tpadding: 10px;\n\tpadding-left: 100px;\n\tbackground: url('/squid-internal-static/icons/SN.png') no-repeat left;\n}\n\n/* initial title */\n#titles h1 {\n\tcolor: #000000;\n}\n#titles h2 {\n\tcolor: #000000;\n}\n\n/* special event: FTP success page titles */\n#titles ftpsuccess {\n\tbackground-color:#00ff00;\n\twidth:100%;\n}\n\n/* Page displayed body content area */\n#content {\n\tpadding: 10px;\n\tbackground: #ffffff;\n}\n\n/* General text */\np {\n}\n\n/* error brief description */\n#error p {\n}\n\n/* some data which may have caused the problem */\n#data {\n}\n\n/* the error message received from the system or other software */\n#sysmsg {\n}\n\npre {\n    font-family:sans-serif;\n}\n\n/* special event: FTP / Gopher directory listing */\n#dirmsg {\n    font-family: courier;\n    color: black;\n    font-size: 10pt;\n}\n#dirlisting {\n    margin-left: 2%;\n    margin-right: 2%;\n}\n#dirlisting tr.entry td.icon,td.filename,td.size,td.date {\n    border-bottom: groove;\n}\n#dirlisting td.size {\n    width: 50px;\n    text-align: right;\n    padding-right: 5px;\n}\n\n/* horizontal lines */\nhr {\n\tmargin: 0;\n}\n\n/* page displayed footer area */\n#footer {\n\tfont-size: 9px;\n\tpadding-left: 10px;\n}\n\n\nbody\n:lang(fa) { direction: rtl; font-size: 100%; font-family: Tahoma, Roya, sans-serif; float: right; }\n:lang(he) { direction: rtl; }\n --></style>\n</head><body id=ERR_DNS_FAIL>\n<div id=\"titles\">\n<h1>ERROR</h1>\n<h2>The requested URL could not be retrieved</h2>\n</div>\n<hr>\n\n<div id=\"content\">\n<p>The following error was encountered while trying to retrieve the URL: <a href=\"https://iecvlist.microsoft.com/*\">https://iecvlist.microsoft.com/*</a></p>\n\n<blockquote id=\"error\">\n<p><b>Unable to determine IP address from host name <q>iecvlist.microsoft.com</q></b></p>\n</blockquote>\n\n<p>The DNS server returned:</p>\n<blockquote id=\"data\">\n<pre>No DNS records</pre>\n</blockquote>\n\n<p>This means that the cache was not able to resolve the hostname presented in the URL. Check if the address is correct.</p>\n\n<p>Your cache administrator is <a href=\"mailto:root?subject=CacheErrorInfo%20-%20ERR_DNS_FAIL&amp;body=CacheHost%3A%20unknown%0D%0AErrPage%3A%20ERR_DNS_FAIL%0D%0AErr%3A%20%5Bnone%5D%0D%0ADNS%20ErrMsg%3A%20No%20DNS%20records%0D%0ATimeStamp%3A%20Mon,%2002%20Mar%202020%2008%3A15%3A25%20GMT%0D%0A%0D%0AClientIP%3A%20172.17.4.64%0D%0A%0D%0AHTTP%20Request%3A%0D%0ACONNECT%20%2F%20HTTP%2F1.0%0AContent-Length%3A%200%0D%0AProxy-Connection%3A%20Keep-Alive%0D%0APragma%3A%20no-cache%0D%0AHost%3A%20iecvlist.microsoft.com%3A443%0D%0A%0D%0A%0D%0A\">root</a>.</p>\n
\n</div>\n\n<hr>\n<div id=\"footer\">\n<p>Generated Mon, 02 Mar 2020 08:15:25 GMT by unknown (squid)</p>\n<!-- ERR_DNS_FAIL -->\n</div>\n</body></html>\n", 3932) = 3932 <0.000044>



### Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.6 (Maipo)


### How reproducible:

sometimes


### Steps to Reproduce:

N/A


###Actual results:

See ###Description of problem


### Expected results:

squid-3.5.20-12.el7_6.1.x86_64                              Thu Jul 18 22:26:54 2019
squid-migration-script-3.5.20-12.el7_6.1.x86_64             Thu Jul 18 22:25:55 2019

Comment 2 kazuhiro kawana 2020-03-04 11:51:18 UTC

*** This bug has been marked as a duplicate of bug 1810005 ***


Note You need to log in before you can comment on or make changes to this bug.