Bug 1810064 - cloud-init Azure byte swap (hyperV Gen2 Only) [rhel-7.8.z]
Summary: cloud-init Azure byte swap (hyperV Gen2 Only) [rhel-7.8.z]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cloud-init
Version: 7.7
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Eduardo Otubo
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On: 1788340
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 14:04 UTC by RAD team bot copy to z-stream
Modified: 2020-06-23 12:21 UTC (History)
15 users (show)

Fixed In Version: cloud-init-18.5-6.el7_8.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1788340
Environment:
Last Closed: 2020-06-23 12:21:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2654 0 None None None 2020-06-23 12:21:51 UTC

Description RAD team bot copy to z-stream 2020-03-04 14:04:19 UTC
This bug has been copied from bug #1788340 and has been proposed to be backported to 7.8 z-stream (EUS).

Comment 7 Huijuan Zhao 2020-03-30 11:00:52 UTC
Regression test with cloud-init-18.5-6.el7_8.1 on Azure/AWS - Pass.

Hi Dan,

Could your team please help to validate the official RHEL 7.8.z cloud-init fix? 
Please get the package here: http://people.redhat.com/huzhao/cloud-init-18.5-6.el7_8.1.x86_64.rpm

Thanks!

Comment 8 Dan 2020-04-02 13:56:12 UTC
Hi, we tested the package, passed successfully! thanks!

Comment 9 Huijuan Zhao 2020-04-02 15:12:51 UTC
(In reply to Dan from comment #8)
> Hi, we tested the package, passed successfully! thanks!

Dan, thank you so much for the testing and update.
Change the status to VERIFIED.

Comment 14 Huijuan Zhao 2020-04-16 03:25:44 UTC
Hi Dan,

Here is the latest 7.8.z cloud-init package, you can build Azure rhel 7.8 on-demand image without having to wait for the official 7.8.z update later in May. This package contains one additional fix that was added to the 7.8.z errata since the one you tested in comment 7 and comment 8.

Please get the package here: http://people.redhat.com/huzhao/cloud-init-18.5-6.el7_8.2.x86_64.rpm

Thanks!

Comment 15 Dan 2020-04-16 16:02:45 UTC
Thank you all!!! Hugely, massively appreciated!!!! :-)

Comment 19 errata-xmlrpc 2020-06-23 12:21:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2654


Note You need to log in before you can comment on or make changes to this bug.