Bug 1810071 - [IPI Baremetal] ipxe.efi isn't present in shared tftpboot
Summary: [IPI Baremetal] ipxe.efi isn't present in shared tftpboot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Stephen Benjamin
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks: 1810076
TreeView+ depends on / blocked
 
Reported: 2020-03-04 14:08 UTC by Stephen Benjamin
Modified: 2020-07-13 17:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ipxe.efi wasn't present in the running ironic container Consequence: booting UEFI failed in cases where ipxe.efi was needed Fix: copy ipxe.efi to the /shared directory at runtime Result: UEFI boot no longer effected
Clone Of:
: 1810076 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:18:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:18:34 UTC

Description Stephen Benjamin 2020-03-04 14:08:50 UTC
ipxe.efi was copied at build time, but the shared volume didn't exist.

When trying to provision a host using UEFI, it will fail due to the missing file on the tftp server.

Comment 4 errata-xmlrpc 2020-07-13 17:18:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.