Bug 1810104 - snmpd crashes with segfault while walking host table
Summary: snmpd crashes with segfault while walking host table
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Ridky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 14:40 UTC by Martin Jackson
Modified: 2020-04-28 02:55 UTC (History)
4 users (show)

Fixed In Version: net-snmp-5.8-19.fc30 net-snmp-5.8-19.fc32 net-snmp-5.8-19.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-25 02:41:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Jackson 2020-03-04 14:40:08 UTC
Description of problem:
snmpwalk fails and crashes agent on version 5.8-17.fc31.x86_64

Version-Release number of selected component (if applicable):
net-snmp-1:5.8-17.fc31.x86_64

How reproducible:
every time

Steps to Reproduce:
1.start snmp agent with rocommunity configured
2.snmpwalk host table with configured rocommunity
3.

Actual results:
Agent crashes mid-table

Expected results:
Agent completes query of table

Additional info:
From the query side:
snmpwalk -v2c -c p0ller localhost host 

HOST-RESOURCES-MIB::hrSystemUptime.0 = Timeticks: (12179879) 1 day, 9:49:58.79
HOST-RESOURCES-MIB::hrSystemDate.0 = STRING: 2020-3-4,8:35:15.0,-6:0
HOST-RESOURCES-MIB::hrSystemInitialLoadDevice.0 = INTEGER: 393216
HOST-RESOURCES-MIB::hrSystemInitialLoadParameters.0 = STRING: "BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.5.7-200.fc31.x86_64 root=/dev/mapper/fedora_mithrandir-root ro resume=/dev/mapper/fedora_mithran"
HOST-RESOURCES-MIB::hrSystemNumUsers.0 = Gauge32: 1
HOST-RESOURCES-MIB::hrSystemProcesses.0 = Gauge32: 283
HOST-RESOURCES-MIB::hrSystemMaxProcesses.0 = INTEGER: 0
HOST-RESOURCES-MIB::hrMemorySize.0 = INTEGER: 7786308 KBytes
Timeout: No Response from localhost

Systemctl status indicates the agent core dumped:
% systemctl status snmpd
● snmpd.service - Simple Network Management Protocol (SNMP) Daemon.
   Loaded: loaded (/usr/lib/systemd/system/snmpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: core-dump) since Wed 2020-03-04 08:35:15 CST; 2min 25s ago
  Process: 193309 ExecStart=/usr/sbin/snmpd $OPTIONS -f (code=dumped, signal=SEGV)
 Main PID: 193309 (code=dumped, signal=SEGV)
      CPU: 59ms

Comment 1 Martin Jackson 2020-03-04 14:41:05 UTC
This applies to the version in updates-testing; the regression with the hrSoftwareInstalled table is fixed by -17.

Comment 2 Steve Bennett 2020-04-01 14:44:23 UTC
I'm seeing this same behaviour with 5.8.16 (which is on updates-released for Fedora 30).

Comment 3 Fedora Update System 2020-04-09 16:26:05 UTC
FEDORA-2020-c3ab547325 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c3ab547325

Comment 4 Fedora Update System 2020-04-09 16:26:06 UTC
FEDORA-2020-44b769adaf has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-44b769adaf

Comment 5 Fedora Update System 2020-04-09 16:26:08 UTC
FEDORA-2020-7303a69282 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7303a69282

Comment 6 Fedora Update System 2020-04-10 16:56:25 UTC
FEDORA-2020-c3ab547325 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c3ab547325`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c3ab547325

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-04-10 21:36:56 UTC
FEDORA-2020-44b769adaf has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-44b769adaf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-44b769adaf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-04-11 18:51:00 UTC
FEDORA-2020-7303a69282 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7303a69282`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7303a69282

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-04-25 02:41:01 UTC
FEDORA-2020-44b769adaf has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-04-26 02:50:46 UTC
FEDORA-2020-7303a69282 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-04-28 02:55:56 UTC
FEDORA-2020-c3ab547325 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.