Bug 1810108 - Obsolete several python2 packages
Summary: Obsolete several python2 packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 14:49 UTC by Miroslav Suchý
Modified: 2020-03-16 20:34 UTC (History)
3 users (show)

Fixed In Version: fedora-obsolete-packages-32-38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-16 20:34:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Miroslav Suchý 2020-03-04 14:49:21 UTC
Description of problem:
During upgrade from F31 to F32 I got:


 Problém 7: package python2-fmf-0.6-1.fc29.noarch requires python2.7dist(pyyaml), but none of the providers can be installed
  - python2-pyyaml-5.1.2-1.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-fmf-0.6-1.fc29.noarch
 Problém 8: package python2-txws-0.9.1-15.fc31.noarch requires python2-twisted, but none of the providers can be installed
  - python2-twisted-19.2.1-4.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-txws-0.9.1-15.fc31.noarch
 Problém 9: package python2-txzmq-0.8.0-9.fc31.noarch requires python2-zmq >= 13.0.0, but none of the providers can be installed
  - python2-zmq-18.0.2-2.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-txzmq-0.8.0-9.fc31.noarch

Comment 1 Miro Hrončok 2020-03-04 15:10:27 UTC
$ repoquery --repo={fedora,updates{,-testing}} --releasever 32 --latest=1 --obsoletes fedora-obsolete-packages | grep python2-fmf
python2-fmf < 0.5-4

$ ... | grep python2-txws
python2-txws < 0.9.1-15

$ ... | grep python2-txzmq
python2-txzmq < 0.8.0-9


Yes, those need to be updated :(

Comment 2 Julian Sikorski 2020-03-05 17:23:04 UTC
A few more:
 Problem 1: package gnome-python2-desktop-2.32.0-38.fc31.x86_64 requires gnome-python2-canvas >= 2.10.0, but none of the providers can be installed
  - gnome-python2-canvas-2.28.1-30.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package gnome-python2-desktop-2.32.0-38.fc31.x86_64
 Problem 2: package system-config-keyboard-1.4.0-18.fc31.noarch requires python2-newt, but none of the providers can be installed
  - python2-newt-0.52.21-2.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package system-config-keyboard-1.4.0-18.fc31.noarch

Comment 3 Miro Hrončok 2020-03-05 17:31:53 UTC
gnome-python2-desktop neither system-config-keyboard is obsoleted at all, will add.

In fact, will do this now.

Comment 5 Fedora Update System 2020-03-05 19:36:45 UTC
fedora-obsolete-packages-32-38 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-14e988c430

Comment 6 Fedora Update System 2020-03-16 20:34:12 UTC
fedora-obsolete-packages-32-38 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.