Bug 1810123 - [RFE] Provide ability to add packages to the needs-restarting plugin configuration.
Summary: [RFE] Provide ability to add packages to the needs-restarting plugin configur...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf-plugins-core
Version: 8.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 8.3
Assignee: nsella
QA Contact: Luca Berton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 15:18 UTC by Kyle Walker
Modified: 2020-11-04 01:53 UTC (History)
6 users (show)

Fixed In Version: dnf-plugins-core-4.0.17-2.el8
Doc Type: Enhancement
Doc Text:
Feature: The needs-restarting dnf plugin supports user-defined package lists. If a package from the package list gets updated, the plugin suggests rebooting the system. Reason: Result: Users can place their *.conf files under /etc/dnf/plugins/needs-restarting.d/. The files contain package names, one at each line.
Clone Of:
Environment:
Last Closed: 2020-11-04 01:52:51 UTC
Type: Feature Request
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:4510 0 None None None 2020-11-04 01:53:06 UTC

Description Kyle Walker 2020-03-04 15:18:57 UTC
Description of problem:

    Right now, the list of packages that are checked is a static list.

    plugins/needs_restarting.py
    <snip>
    # For which package updates we should recommend a reboot
    # Mostly taken from https://access.redhat.com/solutions/27943
    NEED_REBOOT = ['kernel', 'glibc', 'linux-firmware', 'systemd', 'dbus',
                   'dbus-broker', 'dbus-daemon']
    <snip>

    This results in the need to rebuild each time a new package name is added
    to the list. This feature is requesting that the plugin provide the ability
    to add packages to the needs-restarting plugin via a drop-in.

    Similar to the following:
      # echo “kernel-rt” > /etc/dnf/plugins/needs-restarting.d/kernel-rt.conf


Version-Release number of selected component (if applicable):
    dnf-plugins-core-4.0.8-3.el8.noarch


Steps to Reproduce:
    Add a package to the needs-restarting plugin

Actual results:
    1. Add the package to the static list
    2. Rebuild the package

Expected results:
    1. Add a drop-in to the /etc/dnf/plugins/needs-restarting.d/ directory

Additional info:

    This was discussed in the context of the following bug report.

      1806060 – 'needs-restarting -r' does not show that a reboot is required after updating the RT kernel in RHEL 7.6.
      https://bugzilla.redhat.com/show_bug.cgi?id=1806060

    A related effort to this request would be to also include the 
    "kernel-rt" package as a new drop-in which would ship along with this RFE.

Comment 16 errata-xmlrpc 2020-11-04 01:52:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (yum bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:4510


Note You need to log in before you can comment on or make changes to this bug.