Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1810137 - DNS resolution over TCP still enforced when double listeners is allowed by Octavia
Summary: DNS resolution over TCP still enforced when double listeners is allowed by Oc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Maysa Macedo
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On: 1819129
Blocks: 1814345
TreeView+ depends on / blocked
 
Reported: 2020-03-04 15:31 UTC by Maysa Macedo
Modified: 2020-07-13 17:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1814345 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:18:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 509 0 None closed Bug 1810137: Delete admission controller if double listeners is supported 2020-06-23 08:59:39 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:18:34 UTC

Description Maysa Macedo 2020-03-04 15:31:56 UTC
Description of problem:


When Octavia double listeners is supported we should delete the existing
DNS admission controller DaemonSet. However, right now we're simply not
applying the DaemonSet in every reconciliation, and not deleting
the existing one.

Version-Release number of selected component (if applicable):


How reproducible:
Deploy OSP 13 upgrade octavia to OSP16. Notice the admission controller is not removed. 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Jon Uriarte 2020-04-03 10:45:00 UTC
Verified in 4.5.0-0.nightly-2020-04-02-115550 on top of OSP 13 2020-03-25.1 puddle.

Upgrading the OSP octavia from 13 to 16 is detected by the cno and acts accordingly,
the admission controller pods are removed as it supports double listeners with the new
octavia version and the amphora driver.

Before the upgrade:
192.168.24.1:8787/rh-osbs/rhosp13-openstack-octavia-housekeeping                         20200325.1          fd95fee9ab93        8 days ago          771 MB
192.168.24.1:8787/rh-osbs/rhosp13-openstack-octavia-worker                               20200325.1          1094566066f0        8 days ago          771 MB
192.168.24.1:8787/rh-osbs/rhosp13-openstack-octavia-api                                  20200325.1          4e9f1355d779        8 days ago          814 MB
192.168.24.1:8787/rh-osbs/rhosp13-openstack-octavia-health-manager                       20200325.1          e5af77858bc8        8 days ago          771 MB

2020/04/03 09:36:59 Checking OVN Octavia driver support
2020/04/03 09:36:59 Detected Octavia API v2.0.0
2020/04/03 09:36:59 Checking Double Listeners Octavia support
2020/04/03 09:36:59 Detected Octavia API v2.0.0

After the upgrade:
registry-proxy.engineering.redhat.com/rh-osbs/rhosp16-openstack-octavia-health-manager   latest              6c3db51cd948        4 minutes ago       876 MB
registry-proxy.engineering.redhat.com/rh-osbs/rhosp16-openstack-octavia-api              latest              57728486c5ce        4 hours ago         1.02 GB
registry-proxy.engineering.redhat.com/rh-osbs/rhosp16-openstack-octavia-housekeeping     latest              756aaa71855f        4 hours ago         876 MB
registry-proxy.engineering.redhat.com/rh-osbs/rhosp16-openstack-octavia-worker           latest              b47734a5a04e        4 hours ago         876 MB

2020/04/03 10:20:27 Checking OVN Octavia driver support
2020/04/03 10:20:27 Detected Octavia API v2.13.0
2020/04/03 10:20:27 Checking Double Listeners Octavia support
2020/04/03 10:20:27 Detected Octavia API v2.13.0

$ oc get po -n openshift-kuryr
NAME                               READY   STATUS    RESTARTS   AGE
kuryr-cni-2brz2                    1/1     Running   0          4m21s
kuryr-cni-2nxql                    1/1     Running   0          4m50s
kuryr-cni-fnmkc                    1/1     Running   0          2m20s
kuryr-cni-hc7f9                    1/1     Running   0          2m49s
kuryr-cni-l2qc8                    1/1     Running   0          3m52s
kuryr-cni-z6bd4                    1/1     Running   0          3m23s
kuryr-controller-54758f9f5-fdlhq   1/1     Running   0          4m53s

Comment 5 errata-xmlrpc 2020-07-13 17:18:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.