Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1810153 - fix leaking device state in files in /run/NetworkManager/devices
Summary: fix leaking device state in files in /run/NetworkManager/devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 15:56 UTC by Thomas Haller
Modified: 2020-04-28 16:54 UTC (History)
10 users (show)

Fixed In Version: NetworkManager-1.22.8-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:14 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:36 UTC
freedesktop.org Gitlab NetworkManager/NetworkManager/-/commit/76984a4af39dd01e5520eba569cd83d6459bc1f6 0 None None None 2020-03-04 16:26:14 UTC

Description Thomas Haller 2020-03-04 15:56:55 UTC
NetworkManager writes the device state to /run/NetworkManager/devices.

The filename of these devices, is the ifindex. That is good, because the ifindex uniquely identifies the file at an time (yes, in practice the ifindex can be repeated, but that is no problem here). Also, the data in /run is only relevant for the current boot -- just like the ifindex.

But NetworkManager would only cleanup stale files when quitting. Usually NetworkManager service is not stopped (except during shutdown/reboot). So, in practice, these files pile up until reboot.

When creating (and deleting) a large number of software devices, this becomes a problem.

Imagine docker/podman that creates veth devices for each container.


Fix that by pruning stale files (from time to time).

Comment 2 Thomas Haller 2020-03-04 16:10:10 UTC
reproducer:


```

Create() {
  printf "#%05d: create device \"test\"\n" "$1"
  ip link delete test &>/dev/null
  ip link add test type bridge
  ip addr add 192.168.193.166/24 dev test
  ip link set test up
  sleep 1
}

Create_n() {
  for i in $(seq 1 "$1"); do
    Create "$i"
  done
}

Create_n 100

```

At the end, look at 

  $ ls -la /run/NetworkManager/devices/


also, while it's running, look at

  $ watch 'ip link show dev test; ls -la /run/NetworkManager/devices/'

Comment 8 Vladimir Benes 2020-03-20 14:38:57 UTC
Test case 'clean_device_state_files' added.

Comment 10 errata-xmlrpc 2020-04-28 16:54:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.